TARGETDIR is undefined, the Directory table seems malformed

Asked By 1170 points N/A Posted on -

Hi experts,

I am working with digital photo album for my collection of the shoot I did from a pictorial session.

When I need to edit some photos, I decided to use photo shop.

When I was about to install it, in the middle of the process there is an error that pops up on my screen that says target directory  is undefined, and the target table is malformed.


TARGETDIR is undefined, the Directory table seems malformed. Aborting…

After seeing this message it thought I used a defective CD installer, but when I tried it to other computer it installed properly.

I suspected my drive is faulty, so I run scan disk to check for some bad sectors, but nothing was found, I am running out of ideas on this error.

Please share some ideas.


Answered By 0 points N/A #124661

TARGETDIR is undefined, the Directory table seems malformed


Dear Jovyhasle,

Sorry to hear about the problem you are facing with this installer. You just try these steps; hope your problem will be resolved.

Make sure you are logged as administrator, run the installer again, if installer did not work then copy the CD to a folder in your hard drive and try to install from hard drive. If all in vain then problem in your operating system and you will need to rebuild.

Other solution:

Create a new Virtual CD and try to install from Virtual Drive instead of original CD Drive.

Hope its work.


Login/Register to Answer

Related Questions