Error 80073712 on installing SP1

Asked By 200 points N/A Posted on -


I've been receiving this error every time I tried downloading an update for Windows Vista Home Premium 64-bit. The specific update I am trying to download is Windows Vista Service Pack 1. I have tried for almost 6 times now and yet, I still have no luck. I keep getting this error:

Windows Update

Some update were not installed

Failed: 1 update

Error(s) found:

Code 80073712 Get help

Most recent check for updates: Today at 1:25 PM

Updates were installed: Today at 10:33 PM (Failed). View update history

You have Windows set to: Automatically install new update every day at 3:00 AM (recommended)

You receive update: For Windows and other products from Microsoft Update

I have tried:

  1. Running a CHKDSK.
  2. Run on safe mode.
  3. Disable trend Antivirus.
  4. Uninstall trend.
  5. Run system checker but the process stopped at 62% and was unable to fix the corrupted files.
  6. Run memtest86.
  7. Set updates manually.
  8. Download and run the system update readiness tool from Microsoft download center

But these steps did not resolve the issue. The last thing I can possibly do is to perform a fresh install of Windows Vista Home Premium, but I don't have an installation disk with me neither a recovery disk. I am thinking, what is the possible cause of this? When I run almost all the possible solution I can, but the error is still present. Does anyone know how to fix this error without using any disk? I am really frustrated and will appreciate any help.

Thanks friends.

Best Answer by zack victre
Answered By 0 points N/A #126513

Error 80073712 on installing SP1


The System Update Readiness Tool for Windows can correct some conditions that cause Windows Update error 80073712 error. 

If the System Update Readiness Tool does not correct the problem, you'll need to repair Windows. Repairing Windows won't damage your personal files or the programs that are installed on your computer.

Once you finish the repair, you'll need to rerun Windows Update to install any updates aren't included on the installation DVD. To repair Windows, follow these steps:

  1. Close all programs, and then restart your computer.

  2. Insert the Windows DVD into the computer's disk drive. Wait for Setup to start. If Setup doesn't start automatically, follow these steps:

    • Click Start, and then type Drive:setup.exe in the search box, where Drive is the letter of your computer's DVD drive (for example, D:setup.exe).
    • In the Programs list, click Setup.exe.
  3. Click Install Now.

  4. Click Go online to obtain the latest updates for installation (recommended).

  5. If you're asked for it, type the Windows Product key.

  6. In the Which kind of installation do you want? window, click Upgrade.

  7. When the installation is complete, restart your computer, and then run Windows Update.


Best Answer
Best Answer
Answered By 0 points N/A #126515

Error 80073712 on installing SP1


When you try to install Vista SP1 from windows update you may receive the error code 80073712. This is the most common problem for many users. I hope this solution will work for you.


The issue is that the WUA 3.0 (7.0.6000.374) upgrade is corrupted,essentially the system reports the WUA to be 7.0.6000.374 but the files on the disk are still from the old version (you can check some of the DLLs like wups.dll, wuaueng.dll etc… in the windowssystem32) … and you cannot install the WUA 3.0 even manually.

  • Delete the following file:  C:windowswinsxspending.xml
  • Since Windows security will not allow you to do this, here under the procedure to take ownership of the file.
  • Run a command prompt with “Run as Administrator”.
  • Type in the following commands.

                  takeown /f C:Windowswinsxspending.xml

                  cacls C:Windowswinsxspending.xml /G <YourUsername>:F

  • Then delete the file and reboot the machine.
  • Reinstall the Windows Update Agent.
Answered By 200 points N/A #126516

Error 80073712 on installing SP1


Hi guys!

Thank you for all those information and suggestions. This problem has already been fixed. I found a good site that helps me resolve the issue. Here is the link for the site:


Related Questions