Unable to run machine in virtual box

Asked By 600 points N/A Posted on -


I am having a problem by using  virtual box. I have not used it before and after installation and configuration. Whenever I tried to run the machine, I was greeted with the following error.

Failed to open a session for the virtual machine Windows 7.
The virtual machine ‘Windows 7’ has terminated unexpectedly during
startup with exit code 1.
Result Code: NS_ERROR-FAILURE (0x80004005)
Component: Machine
Interface: IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

virtual machine error

My system is Intel core I 3 with 2 GB of ram and 500 GB of hard disk. I am using fedora 15 as an operating system. The virtual box machine is windows 7,and the installed operating system on it is windows seven professional trial.

It is very important to run it, as I want to test some of the software performance on windows and Linux and have to prepare a comparison report on the differences of performance on both machines.

On my spare computer I am using Fedora 16 but when I try to start Windows 7 virtually using Virtual Box I am confronted with these errors:

Failed to open a session for the virtual machine Windows 7.

The virtual machine ‘windows 7’ has terminated unexpectedly during startup with exit code 1.

Kernel driver not installed (rc=-1908)

The virtualBox Linux kernel driver (vboxdrv) is either not loaded, or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

‘etc/init.d/vboxdrv setup’

As root. Users of Ubuntu. Fedora or Mandrive should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

I have looked all over the internet for a solution, but I can only find obsolete information that is of no use to me. I'm running the most up to date version, 4.1.12.

Any ideas?

As a side note I managed to get QEMU to work I a minimal fashion, once I get past the Windows screen there is an error, it then proceeds into a loop which can only be broken by a forced shutdown.

I then tried XEN which allowed me to get a little further. When I click the install button it just stays on the Windows screen with the loading circle that keeps on going round and round.

Edit: VT enabled.

Kindly help me in this regard.


Best Answer by Santons
Best Answer
Best Answer
Answered By 0 points N/A #119514

Unable to run machine in virtual box



This error will occur if the user ID is not a member of the vboxusers group or does not write to the box folder permissions of. virtual. Check it and correct it. If the problem persists, go through the following information.

Run the command of fallow in the virtual box


LS – to/dev/vboxdrv

VBoxManage list usbhost

Is the disc flash mounted on the host system? (i.e., shown on the side bar of the Finder as a 'Volume') – if so, just expel (in host/Finder) and see what the host does.

If not > there is an update at Path

Hope this will help you to fix the issue.

Answered By 0 points N/A #119516

Unable to run machine in virtual box


Since the problem started after you did configurations to the windows virtual box, then it seems like you configured it wrongly , and therefore you will need to do the following:

  • You will need to remove all the settings that you had used to configure the virtual box and then make sure that you configure it properly.
  • But since you have said in the question that the application worked fine before you configured it, then I will  suggest that you just use the default settings instead of using some other settings that are resulting to problems.

In case the problem persists, then you may need to reinstall the virtual box again.

-Clair Charles

Answered By 0 points N/A #119518

Unable to run machine in virtual box



This problem arises because of missing some packages as well as headers. For this the kernel do not match. You can run the following commands which may be helpful to you.

If you have knowledge about console, then Run it from console:

Su –c ‘/etc/init.d/vboxdrv setup’

If it fails, then

Su –c ‘yum –y remove virtualbox’

Su –c ‘yum –y install virtualbox’

Another Solution:

You know there are two types of virtual box:

1. Virtualbox

2. Virtualbox ose

Go to oracle virtual box site. Find post installer F and install it.

Link is given here: https://sourceforge.net/projects/postinstaller/

Hope this will work on you.

Answered By 0 points N/A #195742

Unable to run machine in virtual box


I think the problem comes due to two reasons:

Firstly the software has some missing some  files or incomplete files or data downloaded.

Another reason could be wrong or incomplete installation of software. So you will have to try again by uninstalling the virtual box and reinstall it.

Also check your firewall settings and uncheck your software from firewall blocking list. 


Login/Register to Answer

Related Questions