Unable to connect to your IMAP server

Asked By 1170 points N/A Posted on -


At work we have a problem working with our emails. While we are working, an error that advises us that we have already exceeded the number of connection occurs.

Unable to connect to your IMAP server. You may have exceeded the maximum number of connections to this server. If so, use the advanced IMAP Server Settings dialog to reduce the number of cached connections.

This problem will not occur in a particular scenario. Sometimes right after registration, it will occur immediately. Also,there hours’ time after having worked and patterns not that well never in what operation will occur. We tried to use email software, we do not have any problem doing our job, but since Thunderbird is the specification of the companies and we can't use another application. Remember to install the new software that might conflict with Thunderbird. Please share some reflections on our theme.

Thank you.

Best Answer by Nick88
Answered By 0 points N/A #123835

Unable to connect to your IMAP server


Hi !

I think this error is related to IMAP/POP3 server. When you have several accounts opened up in Thunderbird,each time you access a folder ( e.g. Inbox,Thrash,Sent) in an account ,a connection is established with the main server.

Let's take an example. Say you have 3 accounts in thunderbird you are going to open up Inbox, Sent,Thrash for all 3 accounts in the same time. This action produce 9 connections (3 x 3) to the server from the same IP address via port 993. So I searched about this and found that there is a setting called MAXPERIP which decides the maximum connections per a IP. So the default value for this is 5 and you get an error message if the connections that are  made is greater than that value. It will be fine if the number of connections are lower than that setting.

So you can change that value to a higher value in order to overcome your problem.

Hope this will work.

Best Answer
Best Answer
Answered By 0 points N/A #123836

Unable to connect to your IMAP server

  • This is evident due to the configuration of  the IMAP server to allow a certain number of connections per IP address. Thunderbird has given a option to change the number of cached connection to resolve this matter.
  • Open the Thunderbird, go to Menu > Select Tools > Account Settings. Then Select  Server settings under the appropriate account in the Server name & User name. After that click Advanced button and new configuration dialog will appear.
  • Now change the 'Maximum number of server connections to cache' value to appropriate value and the default value is 5.
  • Problem can be solved by reducing number of cached connections.(Probably to 1 or 3 )
  • Or there is another solution for who knows little bit of programming.
  • You can increase the max connections by modifying your IMAP configuration file located at /etc/courier-imap/imapd using the following  commands with a "find and replace":
  • perl -p -i -e 's/^MAXDAEMONS=40/MAXDAEMONS=80/g' /etc/courier-imap/imapd
  • perl -p -i -e 's/^MAXPERIP=4/MAXPERIP=40/g' /etc/courier-imap/imapd
  • Finally to complete the changes restart the courier-IMAP service by typing the following.
  • /etc/init.d/courier-imap stop
  • /etc/init.d/courier-imap start

Good luck.

Login/Register to Answer

Related Questions