Error on my computer’s security certificate

Asked By 20 points N/A Posted on -

Hey Everyone,

I am using Windows XP professional version and when I opened Mozilla Firefox to check my mail , I got the following error :

 Secure Connection Failed uses an invalid security certificate.
The certificate is not trusted because the issuer certificate has expired. The certificate will not be valid until 9/12/2008 8:00 AM. The current time is 1/1/2006 4:14 AM. 
With error code;


It might be some issue with the server’s config or it might be someone trying to impersonate the server.
If you have connected to this server successfully in the past the error may be temporary and you can try again later.
There is a ‘View Certificate’ and ‘Cancel’ button below. When I hit the ‘View Certificate’, a box opens telling me that it could not verify the certificate because it is expired.  And when I click ‘Cancel’, it just pops up. It is not possible to quit the browser window until I clicked on it a few times. But as it was about to exit, an alert box from Mozilla opened asking me to close all the tabs open but I don’t have any open tabs except for that single window. When I started again my browser another with ‘The Connection is Untrusted’ error. I’m running Windows XP.
Best Answer by tucker hall
Best Answer
Best Answer
Answered By 0 points N/A #80715

Error on my computer’s security certificate


The Secure Connection Failed has an error code that relates with the current date. The uses an invalid certificate and that certificate is not trusted because it expired. To repair this, please follow this procedure:

  1. Go to your clock settings or double-click on the time at the bottom of your desktop on your windows task bar.
  2. You will notice that the time and date is incorrect. According to your first screenshot, your current time is 1/1/2006 4:14 AM when you encountered this error. Set your clock to your current date and time.
  3. Restart your browser.

If the error continues from appearing, you can also uninstall Firefox and re-install a clean and updated copy of it. You can download it here:

The Connection is Untrusted error may appear when you visit a secure websites and your communication with the site is encrypted to help the user ensure their privacy. 

To troubleshoot the second screenshot or The Connection is Untrusted Error, Please follow the steps below:

  1. Click on the Add Exception… button below. This will open another box with message, You are about to override how Firefox identifies this site.
  2. The location under the server is automatically inputted in the box. Click on Get Certificate beside the location box.
  3. Then hit the Confirm Security Exception button below.

Restart you browser.

Tucker Hall

Answered By 5 points N/A #80718

Error on my computer’s security certificate



Hey Buddy,
Just take a look at the following:
• Check out ‘date’ and ‘time’ in the clock on your pc: double-click the clock icon on the Taskbar at bottom of the screen. See Secure Connection Failed
• If you are not able to add an exception, but got a pop-up with the ‘error message’ then you may check the pref browser.xul.error_pages.enabled on the about:config page and make confirm that the value is set to true (default).
• And make sure that you are not in (permanent) Private Browsing mode.
Answered By 20 points N/A #80719

Error on my computer’s security certificate


Hello! Thank you for that solution. The issue has been resolved like a magic. Thank you so much!

Login/Register to Answer

Related Questions