WordPress 3.5 image upload error

Asked By 0 points N/A Posted on -
qa-featured

Hello there,

I cannot upload any pictures in WordPress because of this error. Yesterday everything worked just fine and now I am a bit surprised with this error. Does anyone have any idea about this error ? What I did wrong that causes this error ?

Thanks !

Blogging.jpg

An error occurred in the upload. Please try again later.

SHARE
Answered By 574060 points N/A #179146

WordPress 3.5 image upload error

qa-featured

This issue with uploading images to WordPress is usually caused by incorrect file permissions. Your “uploads” directory in WordPress should have proper file permissions or else WordPress will not be able to upload and store the files. There are also times WordPress may not display the files from the upload directory.

To set the right permissions for your “uploads” directory, you need to use an FTP client such as FileZilla. If you are wondering who changed the file permissions, one possible reason is your file hosting provider. Your file hosting provider probably ran an upgrade and it somehow caused the file permissions to change. To fix this upload issue with WordPress, use an FTP client like FileZilla.

Start FileZilla then connect it to your website. When FileZilla is already connected to your website, navigate to “/wp-content/”. You should see the “/uploads/” folder inside. Right-click the “/uploads/” directory then select “File permissions”. See image.

You need to set the file permissions for the “uploads” directory itself including all subdirectories inside to 744. In “Change file attributes” dialog box, enter without quotes “744” in the field for “Numeric value”. Check “Recurse into subdirectories” then select “Apply to directories only”. Click OK then FileZilla will start applying the file permissions into the directories. See image.

In case setting the file permissions to 744 doesn’t seem to work, try setting it to 755. After that, you need to set the file permissions for all the files in the “uploads” directory. Right-click on the “uploads” directory again and then select “File permissions”. In “Numeric value”, change it to 644. Check “Recurse into subdirectories” then select “Apply to files only”. Click OK to apply the changes. See image.

Login/Register to Answer

Related Questions