Unable to run the installer after Mac OS X 10.8 upgrade

Asked By 0 points N/A Posted on -

I got an error when trying to run the National Instruments installer on my Mac OS X. Every time I run the installer, the error will instantly showed up. And it is telling me that the nivisai.mpkg is from unidentified developer. This issue doesn't appear when I first run this prior to upgrading to Mac OS X 10.8. How can I fix this?

"nivisai.mpkg" can't be opened because it is from an unidentified developer.

Your security preferences allow installation of only apps from the Mac App Store and identified developers.

"nivisai.mpkg" is on the disk image "NI-VISA-5.1.2.dmg". Google Chrome downloaded this disk image today at 8.24 AM from joule.ni.com.

Answered By 990 points N/A #117745

Unable to run the installer after Mac OS X 10.8 upgrade


This error is due to your recent upgrade which is the Mac OS X 10.8 and they call this as gatekeeper signing. NI is working hard to fix this issue. You may try the solutions below to run the installer:

The first thing to try is to allow the one-time exception. To do this, right-click the MetaPackage and then choose Open. This will bring the same error window but this time, it has an option to disregard the error and launch the MetaPackage.

Another way is to allow the unsigned installers to run. To do this, you need to alter the security warnings by following the steps below:

1. Choose the System Preferences on Apple menu.

2. Click on the Security & Privacy icon.

3. And then click the lock and then log in with the correct credentials.

4. Tick the Anywhere option under the "Allow applications downloaded from:" section.


Login/Register to Answer

Related Questions