Single instance Error message when opening Glovebox

Asked By 0 points N/A Posted on -

Hello everyone! I am getting an error when I click on glovebox application. At first the error appears at the top of the screen then it moves to the bottom after I click on Yes.

Error: Single instance Error

The application encountered problem while attempting to determine if any other instance of the software were running. The following problem was encountered.

Failed to open shared memory-failed to release mutex

Do you want to open the application anyway? If another instance open, the glove may fail to connect properly.

Exception thrown

Creating a view of shared memory failed.

At GloveBox.GloveBoxMain.writeHandle(InPtr hWindow)

At GloveBox.GloveBoxMain.OnHandleCreated(EventArgs e)

Application Exiting……..

The error message shown is also attached below. I cannot use the application most of the time because of this error. I have used it continuously but then I stopped using it for two months then now I decided to use it again. But when I tried to use it again, I cannot make it work this time. If you can give any suggestions that would be a great help and I would really appreciate it. Thank you.


Answered By 574115 points N/A #134995

Single instance Error message when opening Glovebox


Since you are already using GloveBox before, try restarting your computer then open it again. If it still doesn’t work, try doing a clean installation of the program again. Uninstall the application then check your computer for any possible errors. Use a disk utility application to check the system. For a much thorough diagnostics on the system, use a disk utility application like PC Tools Performance Toolkit, Norton SystemWorks, or Norton Utilities. Install GloveBox again after this.

If it still doesn’t work, check the system if the program is already running in the background. Maybe you set it to load automatically whenever Windows boots. Check if GloveBox is included in Windows startup. If it loads automatically during startup then this is the cause of the error. Just remove it from startup then restart your computer. Load the program normally on your desktop.

Login/Register to Answer

Related Questions