PosgreSQL installation error Failed to run initdb:1

Asked By 40 points N/A Posted on -

I was installing PosgreSQL when I received this error message, “Failed to run initdb: 1!” (please refer to the image for more details). Did anybody encounter this?

How do I fix this?

Any help would be very much appreciated.



Failed to run initdb: 1!

Please see the logfile in ‘C:Program


Note! You must read/copy this logfile before you click OK.

or it will be automatically removed.


Answered By 0 points N/A #176585

PosgreSQL installation error Failed to run initdb:1


This kind of problem might be a result of antivirus trying to block some components of the program upon installation. Anyway, you have not mentioned the version of the PogresSQL that you were trying to install. So, the first resolution to this issue is that if you have tried to install an old version, try to install the latest ones and check if you have the same error. However, if you insist to use that version or if the version that you are installing is the latest and still have that problem, what you have to do is reinstall the application. 

But before you do that, you have to turn your firewalls off and your antivirus as well. Once you’ve done that, reboot your computer and try installing the application again.

This should help.

Login/Register to Answer

Related Questions