My USB Device is Showing Write Protected

Asked By 650 points N/A Posted on -

I can’t format my SanDisk 8GB USB drive. I can’t even copy paste any of the files or folders fro or into the USB drive.

The disk is write-protected

Remove the write-protection or use another disk

                                  Removable Disk

I am seeing only the message that the disk is write-protected. I have tried it on different USB port, but the result is same. I have also tried on different pc too. Is his the result of virus attack? Or any kind of physical damage has occurred? I have got some important files on that drive. Please give me a solution to fix up the USB drive and get all my documents.

Best Answer by mozak
Answered By 0 points N/A #112043

My USB Device is Showing Write Protected


Hi Truman.

There is a lock key on the USB. If the key lock in USB moves, the USB drive might show protected against writing.

If not, try the following solution:

From start select "run" and then type regedit or you can also go by "C: windowsregedit.exe". This will open the registry editor.

Next, go to HKLM-

HKEY LOCAL machine > system > CurrentControlSet > Control > StorageDevicePolicies

Double-click the button sets the Write Protect on the right pane and in the value data box to 0.

This is the theme. You did your job. Now restart your PC and you will find the solution to the problem.

Best Answer
Best Answer
Answered By 0 points N/A #112046

My USB Device is Showing Write Protected


Hi Trueman,

This is definitely a virus MALWARE,

AFTER that you can now open the driver.  as you can see all the files are hidden, so you to go to your folder option

See attach file and change the setting as you see it

Login/Register to Answer

Related Questions