I need help with WAN Miniport Network Adapter

Asked By 10 points N/A Posted on -

Hello everyone,

I've got some network issues on my Toshiba Satellite laptop. The Network Adapter does not appear on the Device Manager. This is just the first time that I am going to use my Ethernet port, yet it doesn't work. I can use the wireless connection with no issues but the not the Ethernet. The network adapter I am using is WAN Miniport L2TP. I tried searching on the Internet for some help but there is no such issues that matches my query. If there is someone here who encountered the same issue and managed to resolve it, kindly please help me. Thanks.



Best Answer by Walsh Dipasquale
Answered By 0 points N/A #168236

I need help with WAN Miniport Network Adapter


As your Ethernet is not working so you should reinstall the WAN miniport driver. For doing so you need to click on start by typing devmgmt.msc. Then go to the device manager and select "Show Hidden Devices" under the View menu. Then expand network adapters and there you should see the WAN Miniport (IP). Uninstall it for resolving your problem.

WAN miniport driver

Hopefully you would be able to resolve your problem successfully.

Best Answer
Best Answer
Answered By 0 points N/A #168234

I need help with WAN Miniport Network Adapter


Hello there, I have found many people on the Microsoft community with same problem. Unfortunately only few people had their problems solved. And the only way to do is to reinstall your WAN miniport driver.The steps are given below:-

1. Go to the search tab in start and search "devmgmt.msc"

2. Then go to the Device Manager and navigate to "Show hidden Devices".

3. Click on Network Adapters and you should see WAN Miniport.

4. By right clicking it you will see an uninstalling option but you cannot simply do that.

5. Right click on the WAN Miniport and select update driver.

6. Select no when they give you an option to look on windows update.

7. Then select the "Compatible Hardware" and find the MAC Bridge.

8. Install it under force and now you will be able to uninstall it which you couldn't do it in step 5. 9. Now to reinstall it simple download the Devcon.exe from the link. I hope this helps to solve your problem.

Login/Register to Answer

Related Questions