I can’t update Windows Vista because of Error 646

Asked By 40 points N/A Posted on -

Hello, friends!

I need help with updating my system. I have downloaded an update for Windows Vista but it’s not installing.

I get the Error 646 when I try to install this update on my system. 

Windows is showing that this update has been successfully downloaded on the system and when I try to install it, the system restarts as if it is being installed.

But after the loading time, I realize that no update has been installed. The system keeps on showing that the update has failed to install. I first came across this issue on 12th of December 2008, and since that day I have been unable to update my system.

Please help me update my Windows!

Best Answer by ailenetagz
Answered By 25 points N/A #93537

I can’t update Windows Vista because of Error 646



The root, in a nutshell, is to handicap your firewall. If you're using external anti viruses or firewall, temporary disable it. If you're using the built-in Vista Firewall, do the followings:


Go to Control Panel and select security.


Here you can select turn off/on Windows Firewall.


Click apply on “off” (not recommended) and then OK.


Bet at the Windows Update obstruct, move the Try again add.


The download and the installation should start.


And this measure successfully lay. If a reboot is required, re-enable Firewall again after restarting.


By this, result module output for most Vista Update errors

Best Answer
Best Answer
Answered By 0 points N/A #93538

I can’t update Windows Vista because of Error 646


Simple yet effective way to solve it:

Control Panel
User Accounts
User Accounts (in the new window)
Turn User Account Control (UAC) on or off
check the box to turn off UAC
click "OK"
restart computer
run Microsoft updates
reverse procedure to turn UAC back on
or you can try this steps:
Turn off UAC (use MSCONFIG)
1. Click Start. Type MSCONFIG in the Start Search bar and press Enter. 
Note: If UAC window prompts for permission to continue, please click Continue.
2. Click Tools.
3. Highlight Disable UAC, click Launch.
4. Restart the computer and test the issue again.
Note: If you turn on UAC, please launch Enable UAC
Hope this helps you too! 🙂

Login/Register to Answer

Related Questions