Getting an Emulator Error Drivers Fails to Install

Asked By 0 points N/A Posted on -

Hello there!

Can anyone help me out with my MSP430? I am getting an Emulator errors when I try to connect my board to the computer. I was working with my IAR embedded workbench for MSP430 and eZ430 – RF2500.

 When I tried connecting to plug the target board to my computer, the driver fails to properly install. I tried updating my workbench and installed all the necessary programs.

However, whenever I download with my emulator an error window pops up.

I have a screenshot below of the error.


Fatel error: No communication dll found

Session adorted!

I desperately need help fixing this.

Thank you!

Answered By 0 points N/A #158138

Getting an Emulator Error Drivers Fails to Install



Uninstalling Windows Driver and Code Composer Studio v5 programs would be the best solution for this problem. Restart your computer with Launchpad being disconnected. Then reinstall Code Composer Studio and connect the launchpad again. Now, Code Composer will normally program and debug MSP430. If problem still persists, reboot your computer many times. You can also use at least 2 different launchpad. It takes patience to disconnect, uninstall the device from Windows, restart your computer and connect again. You can also delete the drivers. Allow Windows to install drivers from C:/ti/ccsv5/ccs_base/emulation/drivers/msp430. Please be sure also that you have the same set and versions of services running in your computer.

Login/Register to Answer

Related Questions