Final Cut Express HD 3.5 fails to open

Asked By 0 points N/A Posted on -

Hi Friends,

I bought Final Cut Express HD 3.5 a few years ago and had been using it on my Mac Book Pro quite comfortably. Now I tried installing this application on my iMac running 10.6.8 and the installation completed without any issues. However, I cannot launch Final Cut on this machine. Every time I attempt this, Final Cut prepares to open but fails to complete the process and I get the error message shown in the below attachment. This error seems to occur while loading the audio filters. I guess the plugin mentioned in the error message is a leftover from the coding software called impromptu that I had installed and then uninstalled a few months back. So I went ahead and deleted this troublemaker plugin. But I continued receiving this error. Then I rebooted my system and uninstalled final cut and reinstalled it after rebooting again. But this plugin seems to mess with Final Cut. Now I tried repairing permissions and updating every possible software. But nothing seems to work. Can someone help me with this, please? Any help will be greatly appreciated.



Final Cut express HD quit unexpectedly while using the ImpromptuAnalysis plug-in.

Click reopen to open the application again. Click report to see more detailed information and send a report to apple.

Answered By 90 points N/A #184672

Final Cut Express HD 3.5 fails to open



This problem sounds like there are several copies of Impromptu plug-in is present inside your system.

First, uninstall Final Cut Express HD using CleanApp. This will remove Final Cut Express along all files, preferences, components, just like a fresh one.

After completing, install Final Cut Express HD again.

Also, if you don’t want to uninstall, you’ve to remove the plug-in. Remove the plug-in from “HD >> library >> application support >> Final cut express support >> plugins” or from “users >> library >> application support >> Final cut express support >> plugins”.

Now you don’t have to get the error message again.

Login/Register to Answer

Related Questions