Error when compiling a Flex component into SWC file using compc

Asked By 0 points N/A Posted on -


I was using the Component compiler (compc) to compile a Flex component into an SWC file but then I got this error message, see below.  I have tried looking for a solution via the internet but couldn’t find one and so I tried reinstalling Flex 2 SDK, but the error still exists.

Please help me ASAP.



COMPC.EXE – System Error

The program can’t start because MSVCR71.dll is missing from your

computer. Try reinstalling the program to fix this problem.
Answered By 590495 points N/A #97270

Error when compiling a Flex component into SWC file using compc


Maybe the problem is not with your application since it is a missing file and you already reinstalled your application. Maybe you need something installed on your Windows. MSVCR71.DLL is a Microsoft runtime library file that is a component file of Microsoft Visual Studio .NET.

Try installing Microsoft Visual C++ 2010 on your computer and see if it fixes it. You can download Microsoft Visual C++ Redistributable Package at This is only for 32-bit operating systems. If your Windows is a 64-bit type, search Microsoft’s website for 64-bit versions of this installer.

Here’s what this package requires:

  • Windows XP Service Pack 3, Windows Vista Service Pack 2, Windows Server 2008 Service Pack 2, Windows Server 2008 R2, Windows Server 2003 Service Pack 2, Windows Server 2003 R2 32-bit, Windows 7
  • Pentium 900 MHz or higher processor
  • 128 MB RAM
  • 25 MB free hard disk space

Related Questions