Error opening photos with photo viewer

Asked By 30 points N/A Posted on -

Hello friends,

My operating system is windows 7. I have so many photos in my pc & I used to open those files via photo viewer.

But today I got a problem with photo viewer.

It is showing photoviewer.dll file is missing & the photo cannot be opened.

How to solve this?

Best Answer by patrcik
Best Answer
Best Answer
Answered By 0 points N/A #102927

Error opening photos with photo viewer


 Hi David Hardley,

Please follow the below instruction to resolve this problem.

  • First you to enable default administrator account.
  • Go to start menu and click on the Control panel.
  • Then you have to click the view by from drop down menu and choose large items.
  • Then go to Administrative Tools.
  • Then you need to open Computer management.
  • Double click on the local Users and Groups from left side of the computer management.
  • Then go to the user folder.
  • Then go administrator account by right click and click on the properties.  
  • Then you have to put out the Account the disable from the check box.

I hope it will resolve your issue.

Answered By 0 points N/A #102928

Error opening photos with photo viewer


It looks like you have advanced your current operating system (as an example Windows XP) to Windows 7. In a situation like this, this kind of common error occurs. Since in the previous windows version, you have utilized Photoviewer as the defaulting image editor before upgrading to Windows 7.

Again for Windows 7, some definite attributes are slice up and renamed. In a case like this, Windows Photo Gallery could be renamed to Windows Photo viewer. The executable file is not only the element that needs to be modified, but also the dll file has been moved to some other place. And PhotoViewer.dll and relevant other files have been moved to some other folder. Microsoft prefers that you may use a diverse image editor and then correlate it with the equivalent image file type. (REF: Why cannot I right-click an image to modify it in Windows 7?)

You may have the alternatives mentioned below:

Alternative 1: Eradicate the "edit" verb from file type jpeg image

The "edit" verb for jpegfile class was carried over from your Windows Vista install. When you remove this entry, Microsoft Paint by design becomes the default image editor for the particular file type. To eradicate the "edit" verb for jpeg files, open Regedit.exe and find the way to:

HKEY_CLASSES_ROOT jpegfile shell edit

Then Right-click on edit and select Delete.

(it is to be noted that the edit option doesn’t exist under jpegfile in a pure installation of Windows 7.)

Then depart from the Registry Editor.

Alternative 2: Locate a Different Editor as the Default

Despite of erasing the entry, you can swap the (default) verb in the subsequent key, directing to a different image editor application:

HKEY_CLASSES_ROOT jpegfile shell edit command
place (default) value accordingly, such as "C:Program FilesMy Img Editoreditor.exe" "%1"

I wish that this may help you.



Login/Register to Answer

Related Questions