Error in Installing Visual Studio 2008 Professional Edition

Asked By 0 points N/A Posted on -

Hi guys,

I have been having a lot of problems in installing the new version of the Visual Studio Profession 2008 that I have just completed downloading. The version I downloaded is the Visual Studio 2008 Professional Edition (x86 and x64 WoW) – DVD (English). I downloaded this from my school's MSDNAA Site. It was stored as an ISO image so I burned it to a DVD first before I began the installation. 

However, I got an error message during installation about "failing to copy DW20.EXE file". I got the same error when trying to mount the ISO on a virtual drive using Daemon Tools. 

This error occurred in the last part of installation (copying and starting to set up the installation). Immediately as it began installing, this error message popped up:

"The following components failed to install: Microsoft Visual Studio 2008 64bit Prerequisites (x64)". 

Here's a display of what it looked like:

Microsoft Visual Studio 2008 setup failed

Here are the details in the log:

[02/12/10,19:13:41] Microsoft Visual Studio 2008 64bit Prerequisites (x64): [2] c:tempvisual studio 2008 professional edition (x86 and x64 wow) – dvd (english)setup..wcu64bitprereqx64vs_bsln.exe could not be unpackaged because it is not a cabinet. 
[02/12/10,19:13:41] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259. 
[02/12/10,19:13:41] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2008 64bit Prerequisites (x64) are not installed. 

I am using Windows 7 Home Premium x64. All .NET frameworks are installed and verified as functioning. My temp folder is empty. I use it as Administrator (by right-clicking on it) and I tried running it in compatibility mode with XP and Windows Vista (all versions and service packs).

Any idea how this problem can be solved?

Thanks in advance, you, guys!

Best Answer by dilipkumararora1
Best Answer
Best Answer
Answered By 0 points N/A #93739

Error in Installing Visual Studio 2008 Professional Edition



As you are installing Windows 7 on your system, please keep in mind that the 4th Version of .NET Framework is required for proper installation. As I can see in the screen shot that some of the components were pre-requisite of your application, but installation manager couldn't find those packages, like SQL Server, Design tool for 3.5 environment. 

However your visual studio services are installed in the system, but they won't work as you were expecting or at what level you were expecting. Please go through the entire Installation guide available on MSDN site and then try again.

you can check this link:


Answered By 5 points N/A #93741

Error in Installing Visual Studio 2008 Professional Edition


Two things are possible:

That your downloaded package is corrupted, or that burned ISO DVD is not correct.

First download from Microsoft Visual Studio Professional 2008 Trial.

Download and install MagicDisc (virtual drive emulator – freeware application):

Mount downloaded ISO image to your MagicDisc (after installing MagicDisc, you will get a disk icon in systray near the clock – click right mouse button on it, choose the first drive on top and mount ISO image).

Install Microsoft Visual Studio Professional 2008.

Login/Register to Answer

Related Questions