Device Discovery error occurred when tried to start SeaTools

Asked By 30 points N/A Posted on -

Hi experts,


Fatal Error: Device Discovery when I try to start SeaTools. I'm getting this fatal error message when I start SeaTools. I've tried re-downloading the setup file, un-installing it and re-installing Seatools several times but it still getting the same message. I have Microsoft .NET Framework 1.0, 1.1 and 2.0 installed


My system configuration: AMD Athlon 64 3700+ 2.2Ghz 1GB DDR400 RAM Asus A8n-SLi Motherboard 2 x 320GB Seagate Barracuda 7200.10 SATA2 HDDs (in RAID 0 using NFORCE drivers) NVidia Geforce 7900GTX LG DVD-RW 16X 500W PSU (generic) Windows XP Professional with SP3 and all latest hotfixes installed.


Hope for the best resolution. Thanks in advance.

Error: Index and length must refer to a location within the string. Parameter name: length System.String InternalSubStringWithChecks(Int32, Int32, Boolean)

Answered By 0 points N/A #173425

Device Discovery error occurred when tried to start SeaTools


Hi Lorriance,
The error is because some device are obstructing the software to work.
The solution to resolve the error is as below:

1) Close the running applications
2) Restart the system as Administrator
3) Disconnect the Combo USB Hub
4) Disconnect WD External USB Hard Drive
5) Restart the system and login as  user
6) The software will run efficiently

Login/Register to Answer

Related Questions