Can’t run macro on Solidworks 2012 SP1

Asked By 10 points N/A Posted on -

Hello people

I am using the 3D cad software Solidworks 2012. When I run a macro on SW 2011 SP4 it runs perfectly but I am facing a problem when I try to run a macro on SW2012 SP1. I am met with an error every time. The screenshot of the error is attached below:

Microsoft Visual Basic

Object library invalid or contains references to object definitions that I could not be found

OK Help

I also tried my adding a reference before running the 2012 version as you can see in the following screenshot:


But still the same error persists.

Any help will be highly appreciated.

Waiting for your suggestions


Answered By 5 points N/A #181121

Can’t run macro on Solidworks 2012 SP1


Hello Nicholas. This issue is because of damaged files in Solidworks 2012 SP1 and it affects only macros that have User forms.

It seems that the proper solution for you is to Update. You must install the following applications in order for Solidworks to function.

Please download SP6 first. You can go to Windows Update and It will be there, and install it

Download and install Visual Basic 6.0 from the link I have provided you with.

Visual Basic 6.0

And after this please download the Visual Basic 6.0 cumulative update.

Cumulative Update

I hope you will find this information useful.


Login/Register to Answer

Related Questions