Banshee Encounters a Fatal Error on launch

Asked By 0 points N/A Posted on -


I got this error from Banshee when I tried to launch Banshee after a couple of system resets. I was working with software which caused my system to hang and I had to do a hard reset. Later, when I tried to open Banshee, I got the following fatal error which forced me to quit banshee. I tried restarting it and tried opening Banshee again. But even after trying a couple of times, I’m still getting this fatal error. What might have gone wrong with Banshee? Did anyone else encounter a similar problem? Can anyone help me with a fix for this? I’m using Ubuntu 11.04. I have attached a screen shot of the error message received. Thanks in advance.

Encountered a Fatal Error

Exception has been thrown by the target of an invocation.

Error Details

An unhandled exception was thrown: Sqlite error 11: database disk image is malformed (SQL:


DELETE FROM CoreSmartPlaylistEntries WHERE SmartPlaylistID IN (SELECT SmartPlaylistID FROM CoreSmartPlaylists WHERE IsTemporary = 1);

DELETE FROM CoreSmartPlaylists WHERE IsTemporary = 1;


at Hyena.Data.Sqlite.Connection.CheckError (Int32 errorCode, System.String sql) [0x00000] in :0

at Hyena.Data.Sqlite.Connection.Execute (System.String sql) [0x00000] in :0

at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in :0

Exception has been thrown by the target of an invocation.

at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in :0

at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in :0

at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x00000] in :0

at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in :0

at System.Activator.CreateInstance (System.Type type) [0x00000] in :0

at Banshee.Gui.GtkBaseClient.Startup () [0x00000] in :0

at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.StartupInvocationHandler startup) [0x00000] in :0

.NET Version: 2.0.50727.1433

OS Version: Unix

Assembly Version Information:

gkeyfile-sharp (

Banshee.AudioCd (

Banshee.MiniMode (

Banshee.CoverArt (

indicate-sharp (

notify-sharp (

Banshee.SoundMenu (

Banshee.Mpris (

Migo (

Banshee.Podcasting (

Banshee.Dap (

Banshee.LibraryWatcher (

Banshee.MultimediaKeys (

Banshee.Bpm (

Banshee.YouTube (

Banshee.WebBrowser (

Banshee.Wikipedia (

pango-sharp (

Banshee.Fixup (

Banshee.Widgets (

gio-sharp (

gudev-sharp (

Banshee.Gio (

Banshee.GStreamer (

System.Configuration (

NDesk.DBus.GLib (

gconf-sharp (

Banshee.Gnome (

Banshee.NowPlaying (

Mono.Cairo (

System.Xml (

Banshee.Core (

Hyena.Data.Sqlite (

System.Core (

gdk-sharp (

Mono.Addins (

atk-sharp (

Hyena.Gui (

gtk-sharp (

Banshee.ThickClient (

Nereid (

NDesk.DBus.Proxies (

Mono.Posix (

NDesk.DBus (

glib-sharp (

Hyena (

System (

Banshee.Services (

Banshee (

mscorlib (

Platform Information: Linux 2.6.35-27-generic i686 unknown GNU/Linux

Disribution Information:








Answered By 110 points N/A #179578

Banshee Encounters a Fatal Error on launch


This is a common problem which is caused by a system crash or power outage while Banshee is running as well have maybe had another cause too. It looks like Banshee’s database has corrupted. The Banshee FAQ page containing a list of instructions that work most of the time.

To solve this problem you need to run Banshee, remove the corrupt database file. This is located at “~/.config/banshee-1/banshee.db”

Rename it & Banshee can run again. But be careful for that all your settings are lost. If you like to recover it follow this”

1. Open a terminal window & navigate to “~/.config/banshee-1 and install sqlite3: sudo apt-get install sqlite3” (without quotes)

2. Backup the file by copying “banshee. db”.

3. Open database file using “sqlite3: sqlite3 banshee.db”.

4. Do an integrity check with the command “PRAGMA integrity_check;”.

5. Now try the command “REINDEX;

If this solution doesn't work, you can recover corrupted Banshee Database. To do that, run the following command in a terminal.

$ cd ~/.config/banshee-1

$ sqlite3 banshee.db ".dump" > dump

$ mv banshee.db banshee.db.backup

$ cat dump | sqlite3 banshee.db

This will help you to make database backup & recover automatic. Then start Banshee again. If you would like to stay up-to-date on the progress, feel free to CC yourself to the Bug Report.

Hope your headache will be removed.


Login/Register to Answer

Related Questions