Windows XP floppy drive problems

Asked By 0 points N/A Posted on -

I have two hard drives on with windows 2000 server and one new hard drive with a newly installed windows xp pro on it.After loading windows xp on the hard drive and installing all the updates from Microsoft I go into windows explorer and click on the A floppy drive and windows xp doesn’t recognize it. I try to format the floppy disk and it goes all the way through until the end them stops and says it cannot finish.I reboot to the windows 2000 hard drive and it sees the floppy drive. I have also tried a new floppy drive and disks to no avail.

Answered By 0 points N/A #115195

Windows XP floppy drive problems


If the system is in ATA-compatible mode the SATA controller and disk look like regular IDE disks to the BIOS and to Windows. There are no problems with this.

However, to make use of features like Native Command Queueing, the new Advanced Controller Host Interface (AHCI) mode is required. If this mode is enabled, Windows needs a driver in order to be able to read the disk. (This is also true of SCSI disks and controllers, RAID controllers and any additional IDE controllers that aren't at the standard locations.) Also, if booting from that disk, it requires a copy of the driver named ntbootdd.sys in the same location as ntldr and boot.ini (typically the root of drive C). If the right driver to access the hard disk isn't available and the built-in support doesn't work, Windows will blue-screen with an INACCESSIBLE_BOOT_DEVICE code.

Windows 2000 and XP require a floppy disk to be made available at setup time to provide additional storage drivers. You have to press a key when prompted (F6, from memory) to tell Setup that you want to load additional drivers. Some new systems – which generally don't come with floppy drives – can pretend that a USB memory key is a floppy drive for this purpose.

I'd stick with ATA-compatible mode unless you have good reason to select AHCI mode. AHCI may not even be an option in your BIOS setup – my Dell system doesn't allow it to be selected. 

Login/Register to Answer

Related Questions