No of visitors who read this post: 3847
Category: Misc Software
Type: Question
Author: Simonthames
Your rating: None Average: 5 (1 vote)

Hi guys, I am at work installing a new workstation, when I was done installing the web based application and .net, I meet an error while testing the web application, this error tells me that you must first install one of the following versions of the .NET Framework, see below the whole information of the error.

To run this application, you first must install one of the following versions of the .NET Framework:

 V2.0.50727

Contact your application publisher for instructions about obtaining the appropriate version of the .Net Framework.

When I checked on my web application installation, there was no problem it was just the .net installation, no matter how I try and try again same error was encountered, this is the version of .net I installed on other computer that runs without a problem, please share some ideas on my problem, thanks in advance.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 18444

Hi, for your information any application to run which related to multimedia or the graphic related or the transaction related application on the programming software to run in the Microsoft product that is window 95 or windows 98 or the windows 2000 or the as workstation Windows XP or windows 2003 server or the windows 7 of the windows 2008 server do require or the dependent to with the .net framework. So as by default every windows operating system should be installed just after the operating systems installation, even if the error comes as “To run this application, you first must install .NET Framework” you should take a look at the latest version of the same and should deploy it in the OS.

# Comment Id: 18471

Hi Simonthames,

Here the problem is clear, you will simply be needing .NET Framework 2.0:

The web-based application you installed will not run on .NET 1.1 or other earlier versions of it requires .NET Framework 2.0. What you can do is either uninstall the other versions or install .NET Framework 2.0 together with the others. You will not encounter any error as long as you install everything together.

# Comment Id: 149939

I think even if you know how to install the applications you still don’t know the difference in the environment when the components are installed on different operating systems. Even if the program has the same system requirements for different operating systems, there is still the possibility that the other operating system may require installing additional program to support it.

To download Microsoft .NET Framework 2.0 for your web-based application, visit Microsoft .NET Framework Earlier Versions. This is the right page where you should download the version you want because the one required by the web application is an earlier version. But if you decide on installing the latest version, you may visit Microsoft .NET Framework.

Before installing Microsoft .NET Framework, try uninstalling your web application first to make sure there will be no conflict. After uninstalling the web application, install Microsoft .NET Framework and then install your web application again after that. This is done to make sure that your web application will detect the instance of Microsoft .NET Framework in the system.

Regards
Sharath Reddy