No of visitors who read this post: 410
Type: Question
Author: Clocker
Your rating: None Average: 5 (10 votes)

My PC was working fine before the problem occurred.

When I press the power button the power led lights up but then nothing happens.

The HDD led blinks once or twice then nothing at all but the power led remains on.

Any idea how to solve this?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 3021

Post your hardware info. It definitely looks like a hardware problem and cannot solve until I know the specifications. Post soon. Take Care!

# Comment Id: 3561

  1. Intel core 2 duo 2.2 GHz
  2. Motherboard: gigabyte g31-mx-s2
  3. NVIDIA g-force 9800 GT
  4. 2 gig ram
  5. Creative sound blaster 5:1
  6. 2 hdd, Samsung 160 GB 5200 rpm and Asus 320 GB 7200 rpm

That's my PC.

# Comment Id: 3578

  1. Open the side panel of the CPU
  2. Take out the RAM, clean the head with isopropyl alcohols and then place it back. Make sure it is set properly and the clips on either side clicks back into place.
  3. Push the PSU to Motherboard power connector firmly (don't break it) in its slot.
  4. Check if the HDD power connectors are connected properly.
  5. Start the PC and see if it runs.

        If it still doesn't work,

  1. Take a screw-driver or anything made of metal that conducts electricity.
  2. Find the BIOS reset pins (Should be around the battery, the two pin one, not the three pin)
  3. Short circuit the two pins.

# Comment Id: 3643

You saved my day. Thanks a lot.

# Comment Id: 4900

Might I add to this? The solution is not always using the BIOS reset pins (Thats what you used I guess). There could be other problems, please consider them as well if further problems comes in your way,

  1. Damaged VGA pins, could cause no display.
  2. Damaged Graphics adapter (GPU)
  3. Power supply related problems.
  4. Fried motherboard in the worst case.

Thanks.

# Comment Id: 4905

Thanks for the information but in my case, the reset pins solved the problem, whatever was causing it.

Anyway I will remember your solutions as well, could be handy because the machines could fail every once in a while.