Notepad opens an unreadable ShellClassInfo message

Asked By 200 points N/A Posted on -
qa-featured

Hi,

Whenever I open my desktop computer the notepad automatically opens with a message like this:

[.ShellClassInfo]
[email protected]%SystemRoot%system32shell32.dll,-21787

I don't understand a single word or characters from this error. Though it doesn't seem to cause any more problems, I just find it disturbing that every time I opened my computer this will always appear and that I have to just close it. I want to know how to stop this error from appearing. But first of all, I want to know what is causing this error to trigger every time I boot up.

I already run the SFC /SCAN NOW command to the windows command prompt to instantly initiate or start the WFP or the Windows File Protection, but I really have no luck. I don't remember making any specific changes to my computer's system to make this happen. I repeatedly run Spyware removal tools and Norton 360 but no errors or infections are even recognized.

I searched online and they said, all I need to do is to clean my desktop for any unused icons, programs or software. I already did that but it doesn't change anything. I am running Windows Vista Starter Edition. I also read about an article that this error has something to do with boot. ini and that I need to hide something. But I hardly understand the instructions.

Please help me fix this.

Thank you.

SHARE
Best Answer by Karmen
Best Answer
Best Answer
Answered By 0 points N/A #156320

Notepad opens an unreadable ShellClassInfo message

qa-featured

Hello

There are two reasons why a notepad with that message appears whenever you start up your computer.

One reason is that Desktop.ini exists in one or more of the following location on your computer:

  • C:Documents and SettingsAll UsersStart MenuProgramsStartup
  • C:Documents and SettingsAll UsersStart MenuPrograms
  • C:Documents and SettingsAll UsersStart Menu

And your Desktop.ini contains a line

Either way, why this happened is unknown, it could be a virus, so I suggest a scan before trying to fix it. Now to resolve your issue, you can do one of the following:

Delete the Desktop.ini file

  • Open the Windows Explorer, go to Tools->Folder Options then navigate to the View tab.
  • Under Advanced Settings clear the check on Hide extensions for known file types and Hide protected operating system files by clicking it and click OK.
  • Now go to the locations I specified above, find the Desktop.ini  in each of them, right click then choose Open.
  • Verify if the Desktop.ini contains the line [.ShellClassInfo] [email protected]%SystemRoot%system32shell32.dll,-21787
  • If so, delete that Desktop.ini.
  • Restart your computer and confirm if the problem still occurs.

Use the System Configuration Utility to disable the Startup item

  • Click Start in the search text box type run, in the search result click Run.
  • In Run, type msconfig and then click OK.
  • Go to the Startup tab.
  • Clear the checkbox on any desktop entry in the Startup item column that are listed as column Startup.
  • Click OK.
  • Restart your computer and verify if the problem still occurs
Answered By 210 points N/A #156321

Notepad opens an unreadable ShellClassInfo message

qa-featured

To make it sure, I followed all the suggestions given above, with luck and with your help karmen, my problem is now fixed.

Thank you.

Answered By 572255 points N/A #308818

Notepad opens an unreadable ShellClassInfo message

qa-featured

That content that Notepad always opens on Windows startup belongs to the “desktop.ini” file. This file is a hidden system file located in “C:\Documents and Settings\[your username]\Start Menu\Programs\Startup”. One reason why this file automatically opens up when you start the computer is because its attributes were modified making the file visible instead of hidden. This is Microsoft Windows’ default startup folder.

Anything you put in it will start with Windows and the “desktop.ini” file is located here by default. The reason why the file originally doesn’t start automatically with Windows is because it is hidden. When you put a file into this folder like a shortcut or the program itself, the file has to be visible so Windows can start it.

If the file is hidden, Windows will not find it therefore it will not be executed. To fix your problem, restore the file’s default attributes. Open Windows Explorer then navigate to “C:\Documents and Settings\[your username]\Start Menu\Programs\Startup”. Here, look for the file called “desktop.ini” or probably just “desktop” then right-click it and select “Properties.” In Properties window, in “General” tab, check “Hidden” then click “OK.”

Now, if the checkbox is grayed out, just delete the file and Windows will just recreate it on the next restart.

Login/Register to Answer

Related Questions