Failed to run Synaptic as user root

Asked By 0 points N/A Posted on -
qa-featured

When I run Synaptic, I received an error. Even if I try to add or remove it again, the same error incurs. There is no issue with the permission and I already tried what is suggested in the other site. I also run the command "sudo chown USERNAME .xauthority to no avail. I can still launch synaptic via the terminal. What seems to be the issue here? Any help?

Failed to run /urs/sbin/synaptic as user root.

Unable to copy the user's Xauthorization file.

Close

SHARE
Answered By 564995 points N/A #123082

Failed to run Synaptic as user root

qa-featured

Try doing this. First, open a terminal window. Go to Applications, Accessories, and then Terminal. See image.

Next, type the following in the terminal window and then hit Enter:

  • gksudo synaptic

This somewhat creates the “.Xauthority” file. After that, enter the next command in the terminal window and then hit Enter:

  • sudo chown username:username ~/.Xauthority

Replace both “username” with your actual username. This will then fix the problem. It seems that the error occurs because the “.Xauthority” file is not present or is not yet available. I think the file needs to be created first in some other way before you can use Synaptic. And because the file is really not there it will result in throwing an error because the task somewhat requires copying the “.Xauthority” file to another location.

Login/Register to Answer

Related Questions