Error while installing new dpkg-dev

Asked By 0 points N/A Posted on -
qa-featured

Hello,

I need to update dpkg-dev on my stable Debian. I tried built id from sources. I built dpkg, installed it and installed libdpkg-perl, then I got the following error.

[email protected]:/home/kron/qwe# apt-get -b source libdpkg-perl

Reading package lists… Done
Building dependency tree 
Reading state information… Done
Picking 'dpkg' as source package instead of 'libdpkg-perl'
NOTICE: 'dpkg' packaging is maintained in the 'Git' version control system at:
git://git.debian.org/git/dpkg/dpkg.git
Skipping already downloaded file 'dpkg_1.16.2.dsc'
Skipping already downloaded file 'dpkg_1.16.2.tar.bz2'
Need to get 0 B of source archives.
Skipping unpack of already unpacked source in dpkg-1.16.2
sh: dpkg-buildpackage: not found
Build command 'cd dpkg-1.16.2 && dpkg-buildpackage -b -uc' failed.
N: Ignoring file 'google-chrome.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'dropbox.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Child process failed
 
Please explain me how to get rid of this trouble.
 
Thanks.
SHARE
Answered By 0 points N/A #158438

Error while installing new dpkg-dev

qa-featured

You have not the right amount of things to update the whole setup as it needs few additional features to be added and removed first before continuing to this thing.

  1. Go to the debian website and look for the latest version.
  2. Download the latest version to your computer using a secure connection.
  3. Download the user manual of the software as well.
  4. Open up the manual and there you will see a complete list of options and things needed to install it correctly.
  5. Follow the instructions and you will be all OK.
  6. You can also try downloading the updates only and applying it on the current version but I prefer new installation.

Login/Register to Answer

Related Questions