Error message while running GIMP in Windows XP

Asked By 0 points N/A Posted on -
qa-featured

 

Hi guys,

I am using my Windows XP SP 3 machine and trying to work on a script with the GIMP software. While working with the scripts, I got a strange error message when trying to load one of the Script.  The error message is given below and if anyone got this kind of error before and sort it out, please don’t forget to reply me.

Refresh Scripts Message

Error while loading  /home/O/.gimp-2.6/scripts/

Ev_iccii_photoeffects.scm:

Error: unmatched parentheses:  1

I tried to load the scripts through GIMP software before and that time did not get any problems. It could be that if any kind of change is made, perhaps I might not get any more error messages. If anyone knows what to change, please let me know. Help will be appreciated.

 

SHARE
Best Answer by SpringSang
Best Answer
Best Answer
Answered By 0 points N/A #90026

Error message while running GIMP in Windows XP

qa-featured

Hi Tricia klein,

I think, there are many possibilities that cause the problem that you’ve encountered. Since you didn’t post the code of your script, it’s hard to figure out a specific error. However, it’s worth to try one of the followings to solve the problem:

1. As you stated that “I tried to load the scripts through GIMP software before and that time did not get any problems.” In this case and according to the error message “unmatched parentheses: 1” – this could be simply caused by deleting and/or adding one or more comment(s) in your code. What would happen if you added comment(s) that missing the line endings? Or comment line that is right before a close parenthesis. These comments will comment out all the subsequent text (which is your script’s code) and lead to “unmatched parentheses”.
What to try:
Try to delete (remove) all the comments in your script and re-run it.  Or
Put all your code on a single line (after removing all comments).

2. Have you used any accented characters in variable and/or function names? These accented characters are not valid UTF-8 coded characters. If so, try to change them all.

3. I don’t know which editor you’re using for coding your script, so I assume you are using Notepad (you use Windows XP). In this case, be sure to save filename.scm (you did) and select “All Files” in “Save as type” box. This prevents Microsoft’s Notepad from adding the .txt extension to the file name. And also be sure to select “UTF-8” character set as encoding ( as shows in the figure below).

 

 


I suggest that you should use Emacs as your editor for coding your script. Emacs includes special editing mode for 25 programming languages and scripting language modes. In your case, at least Emacs can help to catch any “unmatched parentheses” errors by highlighting and marking matching parenthesis. You can follow this link “http://www.gnu.org/software/emacs/emacs.html” to obtain one and how to use Emacs at http://www.gnu.org/software/emacs/manual/emacs.html#Program-Modes.

4. To prevent the similar problems and/or others when you work with GIMP, try to:
Avoid using extra parentheses:
By nature, we usually add extra parentheses to a complex mathematical equation (in math) or expression (in programming languages) to make it clearer and readable. This habit may causes problems when we apply in GIMP software.
For Example:
Let say we wanted to add 6 to the result of adding 3 and 5 together:
6 + (3 + 5) 
This is perfect in math and we might be tempted to convert the above statement into GIMP (Scheme) like this:
(+ 6 (3  5)). In GIMP, this is incorrect because the interpreter will think that we are calling function “3” in the (3 5) rather summing up 3 and 5 before adding then to 6. The correct statement should be:
(+ 6 (+ 3  5)) 

Have the proper spacing:
These expressions 4+9; 4 +9; 4+ 9; are all valid in Java, C/C++, C#, Perl…. However, in GIMP (Scheme) we must have a space after any function name or operator for it to be correctly interpreted by the interpreter. 

Always have your GIMP up-to-date:
Upgrade to the latest version of GIMP (GIMP 2.8.0 –for Windows XP SP3 or later) at http://www.gimp.org/downloads/
 
  
Hope this helps and may answer you question.

SpringSang,

 

Answered By 0 points N/A #90028

Error message while running GIMP in Windows XP

qa-featured

Here is a solution:

–          Download the script to your desktop or another folder on your computer. Right click on the script .SCM file and select "Cut" from the menu that appears.

–          Double click the "Computer" icon on your desktop to open Windows explorer. Double click on drive "C:" and navigate to the GIMP script directory. The directory location is:

           C:Program FilesGIMP-2.0Sharegimp2.0scripts

–          Click on "Edit" in the Explorer menu and click again on "Paste." Explorer will copy the script file to GIMP script folder.

–          Start GIMP if it is not already running. The new script will load and be available under the menus. Click on the "Filters" menu, then select "Refresh Scripts" from the Script-Fu menu if GIMP is already running.

–          Click on the GIMP "Filters" menu option and look for the new script under the appropriate filter heading. An animation script will be found under "Filters-Animation". Some GIMP scripts load into other menus if appropriate.

 

Login/Register to Answer

Related Questions