No of visitors who read this post: 478
Category: Misc Databases
Type: Question
Author: Jazzreyes
No votes yet

After attempting to save my edited database that I worked in NI-XNET Database Editor, I am getting an Error -1074384578. Along with the error message are the possible reasons why the error occurred. One of the possible reasons was the unsupported database format.

I am also advised to use an Alias Manager to define an alias name for the database and to deploy the database to the RT system, then use the alias name on the RT system to open the file. I really want to open my edited database with the XNET driver.

Can anyone tell me how will I do that?

Error -1074384578 occurred at XNET Database Save.vi:2

Possible reason(s):

N1-XNET: (Hex 0xBFF6313E) Unsupported database format. For reading a database, the extension must be .xml, .dbc, .ncd, or .ldf. For saving, the extension must be .xml.

When working with a L.abVIEW Real-Time system, use the Alias Manager to define an alias name for the database and to deploy the database to the RT system, then use the alias name on the RT system to open the file.

Continue

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 45905

Hi Jazzreyes,

You may have opened a different format on the XNET database. The editor can only write and read files on the .xml extension. So you need to save the database on an .xml format. You can then edit the file now and save it on the .xml format for later use on your application.

To do this, you need to open the XNET database and go to Start > All Programs > National Instruments > NI-XNET > Database > Editor. Then you need to open the database you want. You then need to  save a copy of the file by going to File > Save as then choose FIIBEX Database file(xml) as the format. You can now edit it.

Aristono