MS-Visual Studio 9.0: Could not be opened for write

Asked By 1170 points N/A Posted on -
qa-featured

Hi techyv people,

My post here is regarding an error occurred while I am using Microsoft Visual Studio 9.0, I meet an error message that tells me "could not be opened for write", this error will pop up whenever I am accessing a file, to help with your analysis of my problem, I am pasting the error screen below.

Studio 9.0Common7Toolsvsvars32.bat’ could not be opened for write.

Error 32003.File ‘C :Program FilesMicrosoft Visual

Studio 9.0Common7Toolsvsvars32.bat’ could not be

opened for write.

This error message that I encountered seems to be a recurring problem, that is why I am posting this issue here in techyv so that many could read this and share some comments, all your comments will be a big help for me in solving this issue, thanks a lot in advance.

SHARE
Best Answer by Enoch Johnson Paul
Answered By 0 points N/A #124809

MS-Visual Studio 9.0: Could not be opened for write

qa-featured

Error 32003 related to read / write administrative rights and this error appears when you don't have full rights. For resolving your issue, right click on vsvars32.bat file and click on properties. Then go to "Security" Tab, under security tab click on "Users".

After click users, you will see below "permission for users". Check on "full control" and "Modify" and "Write" then press OK button. Run your program as "Administrator", you will find your ways to success.

vsvars32.bat file-properties-security-users-permission for users-full control"-"Modify"-"Write
Best Answer
Best Answer
Answered By 0 points N/A #124810

MS-Visual Studio 9.0: Could not be opened for write

qa-featured

Microsoft Visual Studio 9.0 vsvars32.bat could not be opened for writing:

The file affected on this error is the file vsvars32.bat under the folder C :Program FilesMicrosoft Visual Studio 9.0Common7Tools. There are some instances that this file is set as read-only file. You cannot modify a read-only file. As the Microsoft Visual Studio 9.0 to store environment variables on that machine. To change its attribute, follow the guides below:

  1. Navigate the folder and the file and if you have already found the file just right click on it.
  2. Then select the properties on the pop-up menu. A file properties dialog box appears.
  3. On the General tab uncheck the Read-only check box under the attribute's category.
  4. Click Ok.

If the error persists, the issue comes with the security settings on the vsvars32.bat file. You need to change its security settings and give your current account or user name read and write access to the file or a full permission to the file. Here’s the guide with step by step:

  1. Navigate the folder and the file or the vsvars32.bat.
  2. Right click on the file or the vsvars32.bat.
  3. Select properties on the pop-up menu. File properties appear on the screen.
  4. Click the security tab.
  5. On the group or user names list, select your user name then click the edit button. Permissions dialog box pops-up on the screen.
  6. Once again select your user name. If the user name doesn’t exist, just click the add button to add your username.
  7. On the permissions for your selected user name, mark with a check on the Full control on the column Allow. Then click Ok.
  8. Also click Ok on the main properties dialog box.

Login/Register to Answer

Related Questions