VMware Workstation unrecoverable error using VM Guest

Asked By 10 points N/A Posted on -

I have an error when trying to use VM Guest. I am trying to resume the suspended virtual machine.

When I tried to restore it, it is displaying that error "Error While Resuming Suspended VM Guest; VMWare Workstation Unrecoverable Error: (vmx) Exception 0xc0000006 (disk error while paging) has Occurred."

This error is usually related to a problem with the disk while it is being paged. One can find a Virtual Machine log where you can see the errors associated with it. Attached is the screenshot of the errors I have.

Please give suggestions on how to resolve this. Thank you.


Vmware Workstation unrecoverable error:(vmx)

Exception 0x0000006(disk error while paging)has occurred.

A log file is available in "H:WinSrvvmware.log"A core file is available in "H:WinSrv2vmware-vmx-6940.dmp".You can request support and include the contents of the log file and the core file.

To collect data to submit to VMare support,choose "Collect Support Data" from the Help menu.

You can also run the "vm-support"script in the Workstation folder directly.

We will respond on the basis of your support entitlement.

Best Answer by Graham Mcnatt
Answered By 590495 points N/A #154950

VMware Workstation unrecoverable error using VM Guest


Maybe your parent operating system or the actual operating system running on your machine became unstable when your virtual machine was suspended. Try restarting your computer then restart the restoration on the suspended virtual machine.

If the program is reporting a disk error, you should check your hard drive’s file system for any sign of errors. Stop restoring the virtual machine first then check your computer for any possible errors.

Use a disk utility application to check the system. For a much thorough diagnostics on the system, use a disk utility application like Norton SystemWorks, or PC Tools Performance Toolkit. Restart the restoration after doing this.

If the problem is that severe, uninstalling your virtual machine might fix it. Just install it again after successfully removing it.

Best Answer
Best Answer
Answered By 5 points N/A #154951

VMware Workstation unrecoverable error using VM Guest


Hi Olivia,


Having that kind of error because your Virtual Machine is corrupted so to solve this problem try to close the program and restart your computer, when your computer is ready to use launch the virtual machine and see if the same error appear if not, that's good, but if yes, you have to remove the suspended state file but doing this will make all unsaved changes you do before having those errors will lose.

Follow these steps to remove the suspended state file:

Step 1: Go to the folder where your visual machine is saved.

Step 2: Delete the files with the following file extension:

                * .nvram

                * .lck

                * .vmss

Step 3: You can see the .vmx file which is the visual machine configuration file you have to edit it by following these steps:

                1. Backup the existing .vmx file

                2. Delete the vCenter Server's inventory. To delete this you need to right click the visual machine then select the "Remove from Inventory".

                3. Register the new virtual machine from ESZi/ESX command line by launching its then input this text:

                                vmware-cmd -s register /vmfs/volumes/datastore/virtual_machine_directory/virtual_machine_name.vmx

                   Note that the "datastore" is the name of the datastore, the "virtual_machine_directory" is the directory where your virtual machine is saved and the "virtual_machine_name" is the file name of your virtual machine. You have to replace all of that with your own path.

Step 4:  You have to locate the "checkpoint.vmState" then remove all the text inside the double quote.

Step 5: Save everything you change then exit.


Note: You have to make sure that all the changes you made are all correct because it may lead your virtual machine to corruption or failure. If this is happening, save back the .vmx file you backup then try to edit it again.


After successfully removing the suspended state file the error must fix, if not, follow the instruction and make sure to perform each step correctly. If the error still appeared after the second trial, contact their costumer service and report this issue.


I hope the solutions that I gave to you will fix your problem.

Related Questions