TortoiseSVN on my work computer with OS of Vista

Asked By 20 points N/A Posted on -

Hello fellow users,
I have been running the latest stable release of TortoiseSVN on my work computer with OS of Vista, 32bit for some time now, but all of a sudden today almost all of my commits are breaking down (failing mid-commit).
Here are the descriptions in details.
First, I have attempted committing multiple files. I tried to commit a large size of files, over more than 100 and almost 10mb in size. Attempted failed. Afterwards, I kept continuing with smaller portions. Regardless of the size that I made, the commit of those files failed, even when it was down to just 2 small pictures (100kb), or a single xml file.
My internet connection is quite good and there was no interruption during this. Also, I did not find anything faulty with these files, I moved them to my other computer which was able to commit them just fine over the same connection.
I tried to google the problem to find the solution and I found that other svn users (including but not only tortoise svn) are also having this kind of error, but none of the posts had any similar answer to any other post, and all of them were with slightly different situations.
Can you tell me how to get rid of this problem? I really wanted to be able to work from this computer.
Here is the accurate error message shown below:
Commit failed (details follow):
PUT of '<location in svn where file is going>': Could not send request body: An established connection was aborted by the software in your host machine.












Commit – TortoiseSVN Failed

Action Path Mime Type

Command Commit

Adding C:Usersduncamarworkspacemap_repositorytrunkimagesmininwo_imagesgerman_advance.jpg Application/octet-stream

Adding C:Usersduncamarworkspacemap_repositorytrunkimagesmininwo_imagesnwoi.jpg Application/octet-stream

Sending content C:Usersduncamarworkspacemap_repositorytrunkimagesmininwo_imagesgerman_advance.jpg

Sending content C:Usersduncamarworkspacemap_repositorytrunkimagesmininwo_imagesnwoi.jpg

Error Commit failed (details follow):

Error PUT of

Error '/svnroot/tripleamaps/svn/trunk/5100d033e-7ff5-8647-4ed9d50fdo6/trunk/images/mini/cw0_images/nwoi.jpg':

Error Could not send request body: An established connection was aborted by the

Error software in your host mahine.

Error (


204 kbytes transferred in 1 minute(s) and 35 second(s)

The operation failed.


Answered By 0 points N/A #136597

TortoiseSVN on my work computer with OS of Vista



This error message typically occurs when you try to update your working copy. The reason for this error is either:

  –      There are actually 2 different files in the repository whose names differ only in case. This cannot work on a Windows checkout, because the Windows file system is not case-sensitive. It is likely that one of the files got added by mistake, so you need to find out which one, make sure there are no changes committed to the wrong file, and then delete it.


   –      There is a file with an illegal (illegal on Windows) filename. For example names like "con", "lpr", "com", etc. are illegal on Windows because those are device names. And of course names with "/*?:|" and some other special chars in them are also not possible on Windows (NTFS and FAT).

And yes, we know the error message isn't really helpful in this case. But the error message comes from the Subversion library, which we can't change on our own.


Login/Register to Answer

Related Questions