Teracopy Incorrect CRC Check On Files

Asked By 20 points N/A Posted on -

I just recently used Unraid but I am not very familiar  how to work around with it. I have a 4.7 server that has five 2TB and two 1TB Hard drives of different models and brand.

I am trying to copy and move some files from several of my external USB drives and was able to move a total of at least 35 gigabytes of files from a certain drive with the use of Teracopy with CRC mode enabled.

The software has identified several files that did not pass the comparison for the CRC. So I tried to check on these files using md4deep in order to get hashes for md5 for the files that are on the drive and on the array.

Surprisingly, there were no problems and they passed the check. I think that Teracopy may have incorrectly reported that the 4 files have failed the test.

I would like to know if anybody has had the same problem before. It may have some bugs that need to be fixed in order to properly qualify the files being moved.

If it had issues with identifying errors, then it may also have underlying issues when moving files. This has to be addressed immediately.

Answered By 590495 points N/A #156733

Teracopy Incorrect CRC Check On Files


With that drives’ capacity it will really require a lot of time before you finish moving all the files. It is possible that the error you encountered while moving the files using Teracopy may only be a fluke on the process of moving the files and are not permanent errors on the said files.

Since it encountered a CRC error on some of the files, try aborting the process then restart the computer. After booting the system, start moving the files again beginning with the files where the CRC problem was detected.

If the application still encountered the same error on the said files, abort again the process then check your computer for any possible errors. Use a disk utility application to check the system. After this restart again the process.

Related Questions