Latitude E6430 getting a ‘No bootable device found’

Asked By 60 points N/A Posted on -

My Latitude E6430 started not to boot all of a sudden. I get a message saying 'No bootable devices'. If I press F2 to check in the BIOS, the hard drive seems to be detected. I ran some diagnostic tests for the hard drive and it turned out fine. When I tried booting to a DVD, it also did not recognize the disk. What should I do next?

Answered By 0 points N/A #199937

Latitude E6430 getting a ‘No bootable device found’


If the laptop is not finding any bootable devices, but the BIOS detected everything, then your problem comes from the boot menu.

The boot menu offers you a list with all the devices the laptop can boot from. CD/DVD, USB, External HDD, even your own hard disk drive.

The solution is very simple. You said that you could not even boot from a DVD. That means that the boot menu has been altered, and the primary boot device has been changed. So what i recommend is this:

1. Reboot your laptop

2. When the DELL logo is displayed, quickly press the F2 or the F12 key, depending on the laptop.

3. A new menu will be shown with the above mentioned list of bootable devices.

4. Select your hard disk drive and press Enter. It should up normally.

5. If by any chance it still refuses to boot up, then prepare a bootable DVD or USB and then insert it while repeating the same procedure starting from point 1.

Login/Register to Answer

Related Questions