InfoPath the parameter is incorrect.

Asked By 1170 points N/A Posted on -

Hi fellows,

I am using InfoPath Forms Server 2007 on Windows SharePoint Services. While on the process of editing template, such as changing and adding fields, I encountered a problem. Error message popped up that said "the operations fails, some parameter is incorrect". Complete statement pasted below.

InfoPath has encountered an error. The operation failed.
The parameter is incorrect.

I don't have a problem creating new forms. Problem came when I edit an existing form. I tried editing the form in InfoPath and when saving it with a different name, it works. So as publishing it to a new form, the only thing I need to deal with is I cannot edit it using same name.

Please share some views and points on my problem.

Thanks in advance.

Best Answer by Riley weaver
Answered By 0 points N/A #124754

InfoPath the parameter is incorrect.


Dear Martyables,

I’ve read out your problem and here I have a solution for you.

These formats are to be correctly used.

stsadm.exe -o DeactivateFormTemplate -url http://server -filename "C:Template.xsn"
stsadm.exe -o RemoveFormTemplate -filename "C:Template.xsn"
stsadm.exe -o execadmsvcjobs (run this command after removing the template)
stsadm.exe -o UploadFormTemplate -filename "C:Template.xsn"
stsadm.exe -o execadmsvcjobs (run this command again to make sure the upload job has been executed successfully)
stsadm.exe -o ActivateFormTemplate -url "http;//server" -filename "C:Template.xsn"

I think your problem is solved.

Best Answer
Best Answer
Answered By 0 points N/A #124755

InfoPath the parameter is incorrect.


Hello there,

I had a pretty good research on this problem, it’s kind of not so common problem at all. So it requires all the related information about your system. By the way as far I understood this is a problem of SharePoint Services. Please go to this link your PC "C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions12LOGS" and open the log and then do the same so that the error again pops up. Watch the log you will find the error. Now please give us the log problem. By the way, in the mean time try the same thing by creating another account. So many users are telling that it works after making a new account.

Thank you,

Riley weaver


Login/Register to Answer

Related Questions