I got an error when scheduling crawl

Asked By 7060 points N/A Posted on -
qa-featured

I got an error when scheduling crawl. The error message says "0x80070005 E_Access Denied". Please help me to fix this issue and the suggest me the steps to be performed and how I need to perform those steps?

SHARE
Answered By 250 points N/A #83440

I got an error when scheduling crawl

qa-featured

Hello,

Please understand that every time you do crawl scheduling, you are modifying also various data on your server. Therefore, you need to check first the authorizations or certificates on the task folders of your indexer because there might be some modifications or updates happened beforehand.  

After that, make sure to grant modification permissions or rights to your wss_wpg group. To do this, add the wss_wpg account to the C:WindowsTasks folder on your Index server then grant permission. In some cases, you need to right click the Tasks folder then you will see the option “Sharing and Security.”

Check also the event logs and diagnostic logs for possible errors and then you may proceed directly to creating scheduling crawl.

I hope the above information help you to solve the concern. Good luck!

Answered By 575315 points N/A #311095

I got an error when scheduling crawl

qa-featured

The error code “0x80070005” is also known as “Access Denied”. The error normally happens if you don’t have file or registry permission to install the update. This can happen if you are using a standard, non-administrator account. To fix the problem, download the SubInACL Tool and install it. Once installed, start Notepad then copy and paste the following:

@echo off

setlocal

echo.
echo Determine whether we are on an 32 or 64 bit machine
echo.

if “%PROCESSOR_ARCHITECTURE%”==”x86” if “%PROCESSOR_ARCHITEW6432%”==”” goto x86

set ProgramFilesPath=%ProgramFiles(x86)%

goto startResetting

:x86

set ProgramFilesPath=%ProgramFiles%

:startResetting

echo.

if exist “%ProgramFilesPath%\Windows Resource Kits\Tools\subinacl.exe” goto filesExist

echo ***ERROR*** – Could not find file %ProgramFilesPath%\Windows Resource Kits\Tools\subinacl.exe. Double-check that SubInAcl is correctly installed and re-run this script.
goto END

:filesExist

pushd “%ProgramFilesPath%\Windows Resource Kits\Tools”

subinacl.exe /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl.exe /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl.exe /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl.exe /subdirectories %windir% /grant=administrators=f /grant=system=f

echo FINISHED.
echo.
echo Press any key to exit . . .
pause >NUL

popd

:END

endlocal

Save the file as “reset.cmd” then open Windows Explorer and right-click the file and select “Run as administrator”. Wait until the process is complete then restart what you are doing.

Login/Register to Answer

Related Questions