HP PhotoSmart Essential.msi Missing Error

Asked By 30 points N/A Posted on -


I am a HP Photosmart C4280 user in windows7. I was using it for past two months, but now I’m having this problem.


An installation package for the product HPPhotosmartEssential cannot be found. Try the installation again using a valid copy of the installation package "HPPhotosmartEssential.msi".

When I tried to print a file, the error message comes up telling that the file “HP Photosmart Essential.msi” is missing. I didn’t receive any help from HP service Centre either.

Please help me.

Thank you

Best Answer by Felipa Dolore
Answered By 0 points N/A #148935

HP PhotoSmart Essential.msi Missing Error


Hello dear,

hpphotosmartessential.msi download windows 7 error and here is the solution

There are some steps which should be followed.

1. You need the WinRAR software for unzip. Download it from internet and install it

2. Now, you have to download the latest version of Photo Smart Essential. The downloading link is given below: 

3. If the download is finished, then search for the file named pse_350_enu

4. Right click on that file and extract it to the default folder shown by itself

5. Now, run the problem. A window will appear. Select browse and locate  the file that you have just extracted

I think, your problem is solved.

Thanks for your time

Best Answer
Best Answer
Answered By 15 points N/A #148936

HP PhotoSmart Essential.msi Missing Error

To remove this error, you may use the original CD that came with the package and do the following:
1. Insert the CD to your drive.
2. Click Start then click Control Panel.
3. Click "Uninstall a program" under the Programs.
4. On the window, look for all the HP related applications dealing with the printer, quick launch button, and PhotoSmart Essentials, and individually uninstall all of them. If each uninstall requires reboot, do so to ensure that each application is removed thoroughly.
5. Turn off any antivirus program and firewalls.
6. Using the CD perform a fresh install of each application using the "recommended settings" and not the "custom" or "full" setup.
After everything completed successfully, the error should be fixed.

Login/Register to Answer

Related Questions