File or assembly cannot load

Asked By 0 points N/A Posted on -

Hope someone is aware about the following error message. I have already tried to research on the web, with no success. Hope some of you experts will be able to figure this out for me.

I am using Microsoft Visual Studio 2010 version on Windows 7 ultimate machine. The moment I try to add a reference to telerik.Windows.Controls assembly without any references, I get the compilation error message.


Microsoft Visual Studio

Could not load file or assembly ‘Telerik.Windows.Controls, Version=2009.3.1103.1030, Culture=neutral, PublicKeyToken=5803cfa389c90ce7’ or one of its dependencies. The system cannot find the file specified.

Answered By 0 points N/A #115145

File or assembly cannot load



you can try to copy all of the Telerik assemblies, to the Visual Studio public assemblies folder and check if that would fix the issue.  Incase you are not using the Service pack 1 for Visual Studio 2010 & if you have installed the service pack recently and had tried the manual movement of assemblies, prior to the installation, then delete those manually moved assemblies  as Visual Studio will try to reference them, despite the SP1 installation placing everything into the ToolBox. 

If you are still facing any issues, while adding controls like radio button or drop-down, just check the reference in properties to where that assembly is coming from (should be from the installed folder) and reference the other assemblies that you would need for that control. 

In case you need a reference, check out the Control Dependencies page, to see what controls require what assemblies.  And as always, for any RadControls you're using you'll need Telerik.Windows.Controls in there, to start with. 

Also for a better experience, it is good to use .Net Framework 4.0 along with SilverLight 4 rather than 3.0.

Login/Register to Answer

Related Questions