Failed to install , admin rights error

Asked By 0 points N/A Posted on -

I purchased a new HP laptop, which comes with default Windows Vista. I am pretty much new to Windows vista OS and am trying to learn more.

I tried to install RM color magic on my machine and I got an error message which asks me to check my privileges.

RM Colour Magic Installer Information

1: Failed to install ISKernel Files. Make sure you have appropriate privileges on this machine.

I am the only user for my PC and I have all the admin rights. I tried to run the installer, using Run as admin but no use. I tried to stop the firewall and Antivirus services but still the same.

Do I have an option to view if my username has full admin rights? I need to install this software on this machine.

Please help.

Best Answer by monty
Best Answer
Best Answer
Answered By 0 points N/A #96770

Failed to install , admin rights error


This problem has nothing to do with your RM color magic installation. It is a known problem with Windows Vista and its new security restrictions. Here I am giving you 2 solutions for this. First, try with the basic one i. e. Solution 1. I am sure one of these will definitely work:

Solution 1:

Right-click on setup (.exe) file select 'Run as Administrator'. Then disable the User Account Control (UAC) feature, from you Windows Vista Computer. You can disable UAC by using any one of the following methods and then try installation:

        Method 1:      Using MSCONFIG

              (i) Launch MSCONFIG from Run Menu

              (ii) Click on the Tools Tab. Scroll down till you find 'Disable UAC'. Click on that line.

              (iii) Press the Launch button.

              (iv) A COMMAND window will open. When the command is done, you can close the window.

              (v) Close MSCONFIG. You need to reboot the computer for changes to apply.

You can re-enable UAC by selecting "Enable UAC" line and then clicking on the Launch button.

Method 2: Using Regedit

              (i) Open Registry Editor

                (ii) Navigate to the following registry key:


             (iii) Locate the value (DWORD): EnableLUA and give it a value of 0.

             (iv) Close Registry Editor. Reboot the computer.

In order to re-enable UAC just change the value to 1.

Solution 2:

Set the installation program to run in Window XP compatibility mode and set to run as an administrator (even if you are the computer administrator). You do all this by right clicking on the file –> Properties –> Compatibility.

Restart the computer in Safe Mode with Networking (in case any more file downloads are necessary ), and then run the installation program again.

Answered By 0 points N/A #96771

Failed to install , admin rights error


That is problem being caused by the account that you are using, though you have said that you are using the account that has admin rights I will ask you to cross check that again. Usually when you install the windows operating system, there are two accounts that are allocated which are the following:

  • The administrator account and
  • The guest account.

Therefore if you have logged on with the guest account then it does not have sufficient rights to allow you to install the application, and for that reason you will need to switch to an administrator account.

It also be a problem with the application itself. It may be having some credentials on it that are hindering the installation process, and therefore you will need to download another setup application and use it.

-Clair Charles

Login/Register to Answer

Related Questions