Facing The Invalid B-Tree Node Size Problem?

Asked By 0 points N/A Posted on -

I have an iMac with 1TB fusion drive. Once, while browsing in Safari, my computer froze. Then, I booted into recovery mode and erased the Mac OS partition. Then I tried to verify the partition but was unable to do it as an error message popped up saying “invalid b-tree node size”. When I tried repairing the disk, it displayed the same message. I don’t know what happened.

Answered By 0 points N/A #194547

Facing The Invalid B-Tree Node Size Problem?


There is a possible solution for this problem. Just follow the steps.

1) Back up your files using Time machine if you have not done that already.

2) Create Windows 7 bootable USB and boot into it.

3) Keep following the setup till you come across an option to choose the drive where you want to install Windows.

4) Delete all the drives except the Windows 7 one that you just created.

5) Now shut down your system and clear the PRAM using command+option+P+R.

6) Now go to your time machine backup disk and restore the latest backup.

This should do the trick.

Login/Register to Answer

Related Questions