Epson Scanner : no lights and cannot scan

Asked By 60 points N/A Posted on -

I am currently resolving an issue with my Epson Scanner. It has no lights and cannot scan the unit is new so there is just an error somewhere. I tried to power it on and off but received no respond. I also tried to reinstall the unit. Is there another option that I can try?

Answered By 0 points N/A #192083

Epson Scanner : no lights and cannot scan

Are there any lights when you turn it on ? If there are no lights, just be sure that the voltage adapter is connected in a  previous tested outlet.
If there are lights, but the scanner does not respond to the software, be sure that you installed the driver and that the computer is recognizing the scanner. Go to start, right click on my PC, click on manage, click on image devices or input devices, you should see the scanner name, if not, the driver is not installed correctly. Try to do it again.
If the driver is there, connect the scanner using a different USB cable, sometimes this cable has failed out of the box

Hope this helps


Related Questions