Enterprise Library 3.1. installation problem

Asked By 0 points N/A Posted on -


I’m facing a problem with the installation of Enterprise Library 3.1. Something is messed up with the process because when I run it an error message pops-out:

“Enterprise Library 3.1 – May 2007

Enterprise Library 3.1 – May 2007

Please wait while the setup Wizard configures Enterprise Library 3.1 – May 2007. This may take several minutes.

Status: Installing Block Factory

Enterprise Library 3.1 – May 2007

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2869. Ok”

I am open to suggestions on how to solve this problem. So please feel free to collaborate.


Answered By 0 points N/A #92114

Enterprise Library 3.1. installation problem


Hey Paige,

According to my resources, this solution has worked for some. I suggest you try this:

  • Copy the .MSI file to the root directory of your main hard drive>>Open Windows Notepad>>Copy this text to notepad: msiexec /i C:program_name.msi (You can write the whole path of your .msi file in the system, after msiexec /i.)
  • Replace "program_name" in the code you copied, with the actual name of the .MSI file>>Click File>>Save As…
  • Instead of saving it as a .txt file, change it to installer.bat
  • Save the file to your desktop.
  • On your desktop, right click on the file and select Run as Administrator.
  • This will properly run the file to install the application in your system.

Login/Register to Answer

Related Questions