Civilization 2 stopped loading in Vista

Asked By 20 points N/A Posted on -

I was happy to play Civilization II on a Vistalaptop for months, when it stopped loading yesterday. I clicked Civ.exe and nothing happens. I tried restarting the PC but it didn’t help. As a last option I tried to reinstall from the CD Civ II and that didn’t even work! Any ideas?

Answered By 5 points N/A #116156

Civilization 2 stopped loading in Vista


Try the following fixes:

  • With your computer opened, press ctrl+alt+del to open the task manager, and then click on the processes tab. Among the processes, look for Civ.exe and end that process. Close the task manager, restart the computer and then try running the CIV2 application again and see if it will work.
  • If that does not work, you will need to go to the control panel and then locate the CIV2 applications from the list of programs. Click on remove to uninstall it. In case it refuses, then go to C: and then program files and then locate the folder that has that application. Open the folder and delete all the contents, and then go to the control panel and try uninstalling it again.



Login/Register to Answer

Related Questions