Change set X does not exist in the repository

Asked By 10 points N/A Posted on -

We are having problems with our repository.  We are receiving errors such as “Change set X does not exist in the repository.”  This just happened recently and we haven’t encountered this problem before.  I have deleted the repository, reinstalled it and tried to initialize and start fresh.  Even after doing all this I still get an internal server error in the web client stating that I should check the server log file.  I am considering spinning the repository then pushing it to a central server to make it accessible to users on my team.  Do I have to copy the folder to the central server and add the repository there and run vv serve?  Is there a way to recreate the repository on my computer and then push it to the server?  I have no idea what is causing this error and it is still unresolved.  Any idea is welcome.

Answered By 0 points N/A #101112

Change set X does not exist in the repository


Yes you need to create the repository again because there are certain links that are attached to this folder.

  1. Remove or rename the old repository folder. Install the repository again and make the folder.
  2. Restart your computer. Once done. copy it to the folder to the central server and then run.
  3. There is no way to first make the folder on your computer and then push it on the server because as stated earlier, the path will be changed and you will again get the error of internal server.

If you still can't find the solution, better contact an expert which has the experience of 2 3 years of handling queries of intense cases.

Login/Register to Answer

Related Questions