Assembly Cache Viewer -Install failed Access is denied

Asked By 100 points N/A Posted on -

Hi there,

I tried to update my .NET Framework and after downloading when I ran the install package this error appeared. I didn’t find this DLL file to download it and I get stuck with this error. Does anyone have any idea how can I fix this? Please tell what this error means and how can I avoid it in the future?

Thank you!

Assembly Cache Viewer -Install failed

Access is denied: WebPartstepBiStep.dII.


Answered By 590495 points N/A #189277

Assembly Cache Viewer -Install failed Access is denied


If the application depends on Microsoft .NET Framework for functionality and you update your current Microsoft .NET Framework, then that’s probably the reason. There are applications that rely only on a specific version of Microsoft .NET Framework and will stop working once you install a different version of Microsoft .NET Framework. One such good example for this is the program Circle Dock which runs only on Microsoft .NET Framework 3.5.

As an experiment, I tried updating Microsoft .NET Framework to version 4.0 and I am correct. It stopped working after installing Microsoft .NET Framework 4.0. So in your case, restore your original Microsoft .NET Framework to make the program work again. The Assembly Cache Viewer is accessible only on Microsoft .NET Framework 2.0 utilizing the DLL file “Shfusion.dll”.

This is no longer available on higher versions such as Microsoft .NET Framework 3.5 because the DLL file is no longer available. I think if you want to continue using the Assembly Cache Viewer, you need to go back to Microsoft .NET Framework 2.0. If you encountered this problem while installing the new version, check if the version you are installing still supports your operating system because not all Microsoft .NET Framework support all Microsoft Windows operating systems.

Related Questions