Web page set to Google but redirected to Yahoo Mail

Asked By 200 points N/A Posted on -


My home page  has changed itself for the third time. I have set my home age was set to Google, but now every time I open my browser it redirects me to a yahoo pager.

I tried changing the homepage by going to Tools> Internet Options> Changed the homepage to Google then clicked ok.

When I opened it, still bringing me to a yahoo page.

I also tried deleting cookies, cache and browsing history.

So far I got no luck. I can go to other websites it's just that I am unable to change my homepage. 

Please anyone here who can help me?

Best Answer by Tony Montana
Best Answer
Best Answer
Answered By 0 points N/A #112842

Web page set to Google but redirected to Yahoo Mail


Hi Shirley,

Your computer is may be infected by a virus. Adware and Spyware technically not a virus, is a malware that can change homepages, redirect you to websites and open pop ups and pop under when you use your computer. However, it can also be the antivirus itself or some other legitimate software that is changing the homepage.

Here are some things you can do to resolve and prevent this problem from occurring again:

1. Scan in Safe Mode – Using your current antivirus, scan for viruses in Safe Mode to be sure. Most of the viruses and other malware do not work in Safe Mode.

  • Restart your computer and press F8 to go to the Windows Advanced Options Menu.
  • Choose Safe Mode

2. Antivirus feature – If you are certain that it is not a virus that is causing this and you trust the efficiency of your antivirus, then it can actually be your antivirus. There is a feature in some antivirus software that is programmed to protect your homepage since, as mentioned above; there are viruses which do change it. Check the features and settings of your antivirus; it may actually be just doing its job of protecting the homepage that was set to it before.

3. Other legitimate software – AOL is an example of legitimate software that has a feature and a setting to prevent the homepage from being changed, even if you change it in the Internet Options. In some HP laptops, they also have a preinstalled setting that makes the homepage the website of HP as a default. Try to recall what software you may have or had that could have this kind of feature.

4. Get another Antivirus – If you are sure that there is no other software, including your current antivirus, that is doing the change then the next thing to do in this situation is to get another antivirus. Assuming that it is a virus that is causing this problem, then your current antivirus software wasn’t working efficiently enough to catch the virus that has been changing your homepage.

5. Another type of Malware – If you have not found viruses, then it may not be some other type of malicious software that is changing your homepage like Trojans, spyware, adware, keyloggers, etc. There are some antivirus that cannot detect some of these malware or at least the new ones.

6. Spybot Search and Destroy – Is a great tool for searching other types of malware especially Spyware and Adware, which are known for changing homepages of internet browsers.

7. Adaware Internet Security – Is another powerful software for detecting and deleting spyware, adware and other viruses and malware.

8. Kaspersky Internet Security – A personal favorite of mine, it is by far the best protection I have been having.

9. BitDefender – Another good antivirus that does its job efficiently.

10. Reinstall – There is always an option to reinstall your Operating System. Reinstalling of course resets everything and removes any trace of any malicious software or old files and programs. In other words, this is starting with a clean slate.

Answered By 0 points N/A #112843

Web page set to Google but redirected to Yahoo Mail


Hi, Shirley

I can help you fix the issue on your computer. Your homepage is being redirected to other pages because of viruses on your computer or the toolbar for your browser which you may have installed recently.

I suggest you to try these steps:

Make sure that you have not installed any additional toolbar to your browser which has the issue.

If any toolbar is installed, remove it from your computer and try browsing.

If the issue does not get fixed, try reinstalling the browser on your computer.

Just in case the above steps do not help you, scan your computer for any virus infections.

Clean all the infections if any and try again.

Thanks and regards,

Skarbos Jay.

Answered By 0 points N/A #112844

Web page set to Google but redirected to Yahoo Mail


I do not know what is your browser so i tell you one solution that if you want to change your browser home page you can do that  you can change your browser, and you can use Mozilla Firefox  if you have not Mozilla Firefox you can help Google and download Mozilla Firefox then installed Mozilla Firefox.

I can tell you that your problem has been solved for it.

Answered By 0 points N/A #112845

Web page set to Google but redirected to Yahoo Mail


Hi Shirley,

It seems that a browser extension (add-on) that comes with a third party software or a virus in your computer causes this problem to you.

When you are installing new software, especially freeware and trials, it also asks you to install add-ons like Babylon or Ask.com toolbar which may change your default homepage. Your PC gets infected by computer virus automatically when you browse unsafe websites and also through flash drives.

Therefore deleting cookies, cache and browsing history won't solve the problem. You must first remove these browser extensions (toolbars) and here I will give you some ways to restore your homepage back to Google.

1.Do a Full Scan of your computer using Anti-Virus software.

  You will be able to find and delete any computer virus hosted in your PC.

  Then go to Tools > Internet Options and set Google as your home page.

  Then restart Internet Explorer.

  If you don't have an anti-virus software, download Avast using the below link.


  You can get the Free version or try the sophisticated Internet security.

  After scanning your computer try below solutions.

2.Remove the toolbar from Internet Explorer.

  Launch Internet Explorer and then go to Tools > Manage Add-ons

  It will display a list of installed add-ons. Select and disable any toolbar or some other add-on you suspect.

  Then go to  Tools > Internet Options   and set Google as your home page.

  Then restart Internet Explorer.

  Now you should see Google as your homepage. If it is not trying below one.

3.Modifying your System Registry

  On the start menu type regedit and search. Click and open the Regedit.exe
  This will open Registry Editor. ( In  Windows XP open Run and type regedit and click OK to open Registry editor)

  Go to the following registry subkey     HKEY_CURRENT_USERSoftwarePoliciesMicrosoftInternet Explorer

  Right-click and delete it.

  Then go to the following 3 registry subkeys

    HKEY_CURRENT_USERSOFTWAREMicrosoftInternet ExplorerMain
    HKEY_ LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerMain
    HKEY_USERSDefaultSoftwareMicrosoftInternet ExplorerMain

Now change the values of Default_Page_URL and Start Page into https://www.google.com/

Then restart your computer. This should fix your problem.

If you are still having a problem with making Google your homepage in Internet Explorer, Try another web Browser like Google Chrome or Mozilla Firefox.

Hope this Helps.

Login/Register to Answer

Related Questions