No of visitors who read this post: 3155
Category: VPN
Type: Question
Author: Martha Long
Your rating: None Average: 5 (21 votes)

Hi people,

I have been getting this when I tried to connect my VPN.

Internet is working fine meaning my network is okay.

Please take a look.

The VPN client driver has encountered an error.

Cisco AnyConnect VPN client

The VPN client driver has encountered an error.

It was working before and no changes have been made prior to getting this error. It's very frustrating for someone who doesn't know how to troubleshoot this kind of problem. I tried to spend a couple of hours looking for a fix on the internet, but got no success.

I appreciate if you will help me on this one because, I saw some questions here were answered by great working solutions.

Hope to hear from you soon.

Thanks. 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 19165

There are a few solutions to fix this issue.

(The first solution is to replace your antivirus).

To do these you need to:

Uninstall McAfee antivirus or any other antivirus that is installed on your system. Download and install Microsoft Security Essentials antivirus. Choose either the 32-bit or 64-bit depending on the installed operating system. Restart the operating system and try to reconnect to your VPN.

(Another solution is to manually set the AnyConnect VPN agent to Interactive.)

Here are the steps to follow:

1. Right click on My Computer > Manage > Services and Applications > Services > Select the Cisco AnyConnect VPN Agent.

2. Right click Properties, then log on and select Allow service to interact with the desktop.

This sets the registry Type value DWORD to 110 (default is 010) for the.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnagent.

3. Restart the Cisco AnyConnect VPN agent service and reconnect the VPN.

# Comment Id: 154052

If you have been using Cisco AnyConnect VPN Client successfully before, this is probably caused by Microsoft Windows Updates. It is possible that Microsoft Windows Update has recently updated the file certclass.inf and the following error appears in “C:\WINDOWS\setupapi.log”:

  • #W239 The driver signing class list "C:\WINDOWS\INF\certclass.inf" was missing or invalid. Error 0xfffffbf8: Unknown Error. Assuming all device classes are subject to driver signing policy.

To fix it, you need to check which updates have been recently installed on the system. Click Start, Run, and type without quotes “cmd” then hit Enter. In the command prompt window, type without quotes “systeminfo” then hit Enter. To view the output in full screen, press ALT + Enter.

Just hit ALT + Enter again when you are done viewing the information. You can also check “C:\WINDOWS\WindowsUpdate.log” to see the recently installed updates. If you want to try a repair, follow the steps above to open the command prompt. When the command prompt window is up, type without quotes “net stop CryptSvc” then hit Enter.

Examine the database to check the validity using the command:

  • esentutl /g %systemroot%\System32\catroot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb

You may also try renaming the folder “C:\WINDOWS\system32\catroot2” into “catroot2_old”. Select OK when prompted. Exit the command prompt and then restart the computer. If you wish to download a new client again in case you are using an old version, visit AnyConnect Secure Mobility Client.

Regards
Sharath Reddy

# Comment Id: 160146

Hello,

Here is the solution to your problem.

Right Click on My Computer->Manage->Services and Applications->Services. Right click on Cisco AnyConnect VPN Agent and click on Properties. Log on and select Allow service to interact with the desktop

Another solution for your problem, is to open a command prompt (do this by going to Run, and type in cmd) and in the command prompt run net stop CryptSvc and then run esentutl /p %systemroot%\System32\catroot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb

Click OK, exist the command prompt, reboot the PC and there you have it. Your problem is fixed.

I hope this information was helpful to you.

Randolph

# Comment Id: 161155

Hi Martha Long 

I have found another Techyv page which is described about this problem. Go that page and analyze those provided solutions too to fix this issue.

Cisco Anyconnect VPN Client encountering an error