Unable to open connection to hypervisor

Asked By 0 points N/A Posted on -
qa-featured

Hi all of you libvirtd daemon is unable to start. The Virt – manager gives the following error.

"Unable to open connection to hypervisor URI 'qemu:///system': unable to connect to '/var/run/libvirt/libvirt-sock', libvirtd may need to be started: No such file or directory"

I need to know what to do now that i cannot change anything in this configuration and I don't have the technical skills to handle the issue but I simply know that you are there looking and going to react promptly.

Thanks this image represent the error.

Unable to open connection to hypervisor URI 'qemu:///system'

Error:

Unable to open connection to hypervisor URI 'qemu:///system': unable to connect to '/var/run/libvirt/libvirt-sock', libvirtd may need to be started: No such file or directory.

SHARE
Best Answer by Allen Kenneth
Answered By 0 points N/A #123409

Unable to open connection to hypervisor

qa-featured

Hello Vincer,

I have solutions ready for your question. Just try the following steps and let me know if one of these helped you or not.

Solution 1

First, run the following commands as root.

Just start by doing such.

This should allow the daemon to start on boot:

Codes:

  • chkconfig libvirtd on

Then start it.

Codes:

  • rclibvirtd start

Solution 2

This is somehow the same with the first one.

Codes:

  • yum -yinstall libvirtd

Next, start the daemon.

Codes:

  • chkconfig libvirtd on

Lastly,

Codes:

  • Service libvirtd start

I hope one of these will resolve your case.

Charles

Best Answer
Best Answer
Answered By 0 points N/A #123410

Unable to open connection to hypervisor

qa-featured

Hello Vincer, 

I have read about your problem. As the error message shows, the problem is on "libvirtd daemon" that it is not started. Here are a couple of methods which you can try. 

  • Run the following commands as root.

    First allow deamon to start on booting process:
    Code: chkconfig libvirtd on

    Start deamon then.
    Code: rclibvirtd start

Hope this first method itself will fix it.

Or you can try this to start the "libvirtd daemon".  See the image attached

  • Follow this path: Open YAST > System > System Services (runlevel)
    There you will be able to see "libvirtd" under services. Mark it as an enable service.
libvirtd daemon


Hope you will find this useful.

Login/Register to Answer

Related Questions