Permission denied and invalid configuration location

Asked By 40 points N/A Posted on -
qa-featured

Hello Experts,

When I try to configure Eclipse in the system, I stuck up with the error. It says permission denied and invalid configuration location. I login as an administrator but I do not understand why I got this error message. I tried to reinstall it again from the beginning but no luck. Please suggest me some solutions.

Thanks.

 

Invalid Configuration Location

Locking is not possible in the directory “/usr/local/eclipse/configuration/org.eclipse.osgi”. A common reason is that the file system or Runtime Enviroment does not support file locking for that location. Please choose a different location, or disable file locking passing “ – Dosgi.locking=none” as a VM argument.

/usr/local/eclipse/configuration/org.eclipse.osgi/.manager/.fileTableLock (Permission denied)

SHARE
Answered By 70 points N/A #187869

Permission denied and invalid configuration location

qa-featured

Your problem can be solved by adding an extra line in “config.ini” file inside the Eclipse directory.

  1. Open “config.ini”.
  2. At the end of the file, add the following line:
    osgi.locking=none
  3. Save the file.

Now, try to run Eclipse.

Try the following command to launch Eclipse:
$ eclipse -configuration <location>

Here, “<location>” indicates to your home directory.

This should solve your issue.

Also, downloading the latest version of Eclipse might solve this issue. As it is such an IDE that supports thousands of plugins and other components integrated into only one system, it is better to update to the latest version for better performance and stability. Download Eclipse.

Login/Register to Answer

Related Questions