No of visitors who read this post: 5755
Category: Misc Software
Type: Question
Author: Roger Wilson
Your rating: None Average: 5 (1 vote)

I’m having a problem with  maya's error 20 for the past week, and it's getting really very frustrating.

I tried searching for solutions online, but all the solutions are for Mac.

I tried using the solutions of the error 20 in MAC and nothing else happens.

Here’s the error that I get from maya.

 
License was not obtained
Tried Maya 2011 (657C1 2011.0.0.F), error 20
 
License method:
Environment variable MAYA_LICENSE_METHOD='standalone'
 
Product choice:
Environment variable MAYA_LICENSE='unlimited'
 
License file override:
Environment variable MAYA_ALT_EN is not set 
 
Do you have any ideas on how to fix this?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 20162

You can solve your problem by following these steps

  • Deleting folders as noted in the post in discussion.
                /Library/Application Support/Autodesk/Adlm/
                /Library/Preferences/FLEXnet Publisher/FLEXnet/

Installed as Trial first using 000-00000000.

  • Ran Maya as Trial.
  • Then registered afterwards by choosing Activate instead of Try.

# Comment Id: 22431

According to what I have researched, you usually get this error if you have changed your hardware.

Typically the motherboard, video card, hard drive are critical parts in running programs.

If you have changed your hardware, make sure all the drivers are being uninstalled and reinstalled in order to have a compatibility of the program.

When uninstalling the drivers, I recommend you using the Perfect Uninstaller.

This tool will delete any file associated with the program like the files residing in the registry and any other left over files in the system.

You need to uninstall the Maya too using the Perfect Uninstaller to give it a fresh start.

# Comment Id: 149631

It seems that this problem is similar to the license problem encountered in Autodesk Max which is related to a corrupted file in the installation folder. Here in Maya, there are users who finally fixed it by simply deleting the file called “Maya.env”.

If you are confused why is it necessary to delete this file since you can reinstall it, the answer to this is because even if you uninstall Maya, this file will remain undeleted in the installation folder.

This also means that when you uninstall the product, the process will not remove the installation folder together with this file still intact inside.

And when you install it again, since the file is still inside, the installation wizard will detect it and therefore will not replace it and that’s why it is still corrupted even if you reinstall it countless times.

So the solution is to delete “Maya.env” in your hard drive.

For Windows XP and Windows 7 users, you can find this file in these locations:

  • C:\Documents and Settings\username\My Documents\maya\version
  • C:\Documents and Settings\username\My Documents\maya
  • C:\Users\username\My Documents\maya\version
  • C:\Users\username\My Documents\maya

For Mac OS X users, you can find it here:

  • /Users/username/Library/Preferences/Autodesk/maya/version
  • /Users/username/Library/Preferences/Autodesk/maya

And for Linux users, you can find it here:

  • ~/maya/version
  • ~/maya

When you found the file, simply delete it and then open Maya again.

The software will create a new “Maya.env” file.

Regards
Sharath Reddy

# Comment Id: 160967

Hello  Roger Wilson 

There is another Techyv post which is addressed your problem . So check out that page and get more idea to resolve this issue.

License not obtained error received on installing Maya 2011 on Wi…