Stop Automatic Restart after an update

Asked By 400 points N/A Posted on -
qa-featured

This is really annoying. I set my updates to automatic so just in case I have forgotten to install some important software, windows will do it automatically for me. But in order to take the changes effect, we need to reboot our computer. And this always happens even if I am in the middle of doing something really important.

I am using Windows XP Home Edition Service Pack 2 32-Bit Operating System. I want to know how to get rid of this automatic restart after an update? I just don't like to see that window which constantly nagging me and as if I have no choice but to restart now. Choosing restart later, then it will pop up again after 10 minutes. Even if this isn't what I want, I force myself to turn off my updates when I  am working on something. Then just turned it on after working.

I searched on a site but they said, I need to run gpedit.msc but since I am using Windows XP Home Edition and it does not have a gpedit there, what alternative way can I use to fix this?

Do I need a third party software to do this since my XP Home doesn't have gpedit command on run window?

 Automatic updates error

 

Updating your computer is almost complete. Your computer needs to be restarted for the updates to take effect. Windows will restart your computer automatically on 4:56 minutes.

I need advices. Please help.

SHARE
Best Answer by tass0731
Best Answer
Best Answer
Answered By 0 points N/A #112569

Stop Automatic Restart after an update

qa-featured

Hi James,

You can try disabling it without using the gpedit.msc.

Go to Start > Run > type “regedit.exe” and then select “HKEY_LOCAL_MACHINE”. Then go to Software > Policies > Microsoft > Windows > WindowsUpdate then select AU. Right click the “NoAutoRebootWithLoggedOnUsers” and choose Modify. Change the value to 1, which means to disallow auto-reboot. So if ever you want to allow auto-reboot again, you can change it back to 0.

The setting will only take effect as long as you are logged on. So the next time you start (or restart) your computer, the settings will go back to “0”.

Tanasis

Answered By 400 points N/A #112570

Stop Automatic Restart after an update

qa-featured

Thanks tass0731. Good thing your instruction is complete and very clear. I manage to followed it correctly. Thanks again.

Login/Register to Answer

Related Questions